Nvidia Drivers

Discussion about various official QPKG software applications. Login required to view the contents.
User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9390
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: Nvidia Drivers

Post by Moogle Stiltzkin » Fri May 31, 2019 6:11 pm

actually, after i first updated to qts 4.4.1 it updated it to kernel 4.4.1.0949


However TODAY, a new update came out for this in appcenter via qts.
NVIDIA GPU Driver 2.1.2
( 2019/05/31 )
[Fixed Issues]
Fixed an issue that caused Container Station to behave abnormally in QNAP NAS rackmount devices running QTS 4.4.0 and later versions.
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

franka
New here
Posts: 4
Joined: Fri May 31, 2019 4:20 pm

Re: Nvidia Drivers

Post by franka » Sat Jun 01, 2019 12:34 am

@Robert_73 and Moogle Stiltzkin: thank you for your help. Unfortunately nothing has done the thing: neither reinstalling 4.1.1.0949, followed by installing the 2.0.0 or the 2.1.2 Nvidia Driver nor installing manually the driver 2.1.2 after reboot.

The German support site asked now the Taiwan support. Will be interesting what will happen as next.

twitchibob
New here
Posts: 6
Joined: Wed Aug 10, 2016 1:37 pm

Re: Nvidia Drivers

Post by twitchibob » Mon Jun 03, 2019 8:40 am

@Robert_73 Thanks for the heads up on the driver! Its is now working, and running the updated qpkg for the NVidia driver and kernel. I ended up going into the CLI on the device and running the rmcfg to rid my NAS of the out of date version. Once I downloaded the kernel driver from the QNAP site, it installed fine as a manual package add to my NAS. I installed the Nvidia 2.0 qpkg driver I had downloaded earlier this week, and it finally installed without issue. It immediately alerted me that it was out of date and updated to the latest version (which I believe addresses this issue already). Working as it should now. Thanks for your assistance!

franka
New here
Posts: 4
Joined: Fri May 31, 2019 4:20 pm

Re: Nvidia Drivers

Post by franka » Wed Jun 05, 2019 1:11 am

Yesterday I'd sent the German QNAP support my logfiles, and today there was a new NVidia-Version 2.1.3 with "fixed installation issue" on it. Installation is now working.

But: I don't see any information about the GPGPU-Card, just the manufacturer (NVidia Croporation) and the model (GP107 [GeForce GTX 1050 Ti]). The rest is still missing.

Edit: the HybridDesk Station (current version 4.0.2) can't be activated, too. Also the new installed NVidia-driver is greyed out. Same with the CodexPack in v4.6.0.3. Well, it's not getting boring... :)

User avatar
Trexx
Ask me anything
Posts: 5304
Joined: Sat Oct 01, 2011 7:50 am
Location: Minnesota

Nvidia Drivers

Post by Trexx » Wed Jun 05, 2019 5:29 am

There have been issues in the past with various optware/entware versions causing problems with Nvidia drivers due to changes they make with /opt.

One symptom was missing information.

Do you have any of those installed?


Sent from my iPhone using Tapatalk
Paul

Model: TS-877-1600 FW: 4.4.3.x
QTS (SSD): [RAID-1] 2 x 1TB WD Blue m.2's
Data (HDD): [RAID-5] 6 x 3TB HGST DeskStar
VMs (SSD): [RAID-1] 2 x 500GB Evo 860
Ext. (HDD): TR-004 [Raid-5] 4 x 4TB HGST Ultastor
RAM: Kingston HyperX Fury 64GB DDR4-2666
GPU: EVGA GTX 1060 6GB
UPS: CP AVR1350

Model:TVS-673 32GB FW: 4.4.3.x Test/Backup Box
Model:TS-228a FW: 4.4.3.x Test/Backup Box
-----------------------------------------------------------------------------------------------------------------------------------------
NAS RAID Rebuild Times | Live QTS Videos | | QNAP NAS Guide | Information needed when you ask for HELP | QNAP Links, Tutorials, etc.
2018 Plex NAS Compatibility Guide | QNAP Plex FAQ | Moogle's QNAP Faq

franka
New here
Posts: 4
Joined: Fri May 31, 2019 4:20 pm

Re: Nvidia Drivers

Post by franka » Thu Jun 06, 2019 6:05 pm

Dear Trexx,

sorry for my late response and thank you for your response.

I'm rather new with QNAP, and my previous NAS won't have such installation routines with apps (Netgear ReadyNas). What do you mean with "optware/entware"? Third party apps?

If so, they optware-/entware-apps worked fine with the previous version of the QTS-OS (4.3.6). The only change I made is to update QTS to the new version 4.4.1.0949. After installing it, a lot of other apps wanted to be updated, too (including NVidia drivers). All worked fine, instead of the NVidia driver.

At the moment there's no response from the QNAP-support. The case is still at the support team in Taiwan.

Cheers,
Frank

jasonhollis
Starting out
Posts: 16
Joined: Tue Dec 22, 2009 3:41 pm

Re: Nvidia Drivers

Post by jasonhollis » Sun Jun 09, 2019 2:30 pm

I'm thinking about a TS-1677 which has the Risen 7 1700 in it. If I go to this box with a big Nvidia card will I be able to get the Nvidia drivers up and running properly?

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9390
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: Nvidia Drivers

Post by Moogle Stiltzkin » Sun Jun 09, 2019 2:46 pm

jasonhollis wrote:
Sun Jun 09, 2019 2:30 pm
I'm thinking about a TS-1677 which has the Risen 7 1700 in it. If I go to this box with a big Nvidia card will I be able to get the Nvidia drivers up and running properly?
with QTS 4.4.1 did the nvidia driver support get much much better.

what changed with the new nvidia drivers is now hardware accelerated graphics card (nvidia) is better supported by apps like plex and emby. Did you see my review
viewtopic.php?f=45&t=148720#p716418

According to the dev, prior to qts 4.4.1, emby did not detect nvidia graphics, but now it does. Plex nvidia graphics HW/A works but with some limitations for now, you should ask trex and others more familiar with it about the current beta status.

You can also use the nvidia graphics pass-through in VM as well.

or use it for transcoding with the native app videostation.


In the graphics setting you have 3 options
- dedicate to vm
- dedicate to QTS
- dedicate to container station

you can only have 1 of these active only. i believe that if you change modes, you are required to also reboot your QNAP as well. so you can't just simply hit apply and expect it to work, as you may be required to reboot.


you can check the nvidia graphics card compatibility here. i believe the latest RTX 20xx graphics are supported
https://www.qnap.com/en/compatibility/


also if you do plan on getting a x77, they MAY have refreshed the ryzen cpu to the Ryzen 2700, so you may want to confirm this with the QNAP sales and vendor prior to purchase :wink:

viewtopic.php?f=12&t=148898&p=717504&hi ... sh#p717451
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

jasonhollis
Starting out
Posts: 16
Joined: Tue Dec 22, 2009 3:41 pm

Re: Nvidia Drivers

Post by jasonhollis » Sun Jun 09, 2019 5:54 pm

Understood on being able to set where the card is pointed. I just know that at some point you needed Intel Quick Sync as well with Plex.

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9390
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: Nvidia Drivers

Post by Moogle Stiltzkin » Sun Jun 09, 2019 6:21 pm

jasonhollis wrote:
Sun Jun 09, 2019 5:54 pm
..
there is a spreadsheet here comparing transcoding with and without intel quicksync
https://docs.google.com/spreadsheets/d/ ... tmMPc/edit
https://support.plex.tv/articles/201373 ... lity-list/

the nvidia graphics hw/a does more or less the same but with better transcoding quality. you can youtube to see a visual comparison.

but the nas model with intel cpu and quicksync on it, thats 1 less purchase for a graphics card.

my ts-877 cpu software transcoding works fine with 1080p, has a beefy cpu. not sure about 4k stuff :S would hw/a help for that? i don't have a plex pass so i can't test for that.
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

jasonhollis
Starting out
Posts: 16
Joined: Tue Dec 22, 2009 3:41 pm

Re: Nvidia Drivers

Post by jasonhollis » Sun Jun 09, 2019 6:53 pm

Does your 877 have an i3? I tore the i3 out of my TS-1079 and put a Xenon in it. I'm just doing it in software as well but I have all of my apps containerised and I do have a Plex Pass but I have a good mate in SF and I administer his TS-1685. He's thrown an Nvidia card in it for me to play with from here (Melbourne). I think with 4.4 we should have the HW Decode for 4K running in the containerised version of Plex which is really my objective. For my own upgrade it looks like there is way more bang for the buck in the 1677 with the Ryzen 7 1700 versus the Xenon D531. My only concern is Plex needing quicksand to work with the Nvidia but this is probably the wrong forum for that :-)

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9390
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: Nvidia Drivers

Post by Moogle Stiltzkin » Sun Jun 09, 2019 7:10 pm

jasonhollis wrote:
Sun Jun 09, 2019 6:53 pm
...
uh ... no. the ts-877 uses ryzen cpu :mrgreen:

i got mine early on so i don't have the newer ryzen cpus (i'm using the gen1 ryzen). Some of the users they opted to upgrade their own ryzen cpus, but i didn't feel too bothered to do so. works fine for my needs :) (lots of cores/threads)

oo so your into 4k. i'm still on 1080p because it's space efficient for storage and i mostly watch on a 24'' so it's fine for me. for 4k i use netflix on the hdtv :D

so you opted for the containerized plex? yeah makes the updating just work. rather than having to download the plex qpkg and updating manually all the time.

i use the qpkg, cause i'm not so good at setting up the container properly. qpkg is much easier for me to handle :)
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

jasonhollis
Starting out
Posts: 16
Joined: Tue Dec 22, 2009 3:41 pm

Re: Nvidia Drivers

Post by jasonhollis » Sun Jun 09, 2019 7:15 pm

Containers are not really too tough. You should dig into it. I've not been running the QPKG in about 2 years now. The nice thing about the containers is that you don't have all the compatibility issues that I used to see running packages. I run Sonarr, Radarr, SABNZBd, Lidarr and Plex all in their own containers. I have 30TB so I'm less worried about the size of 4K. Also in Oz streaming 4K can still be problematic.

scsherman
Starting out
Posts: 11
Joined: Sat Jun 08, 2019 10:40 am

Re: Nvidia Drivers

Post by scsherman » Sun Jun 16, 2019 1:24 pm

jasonhollis wrote:
Sun Jun 09, 2019 2:30 pm
you can check the nvidia graphics card compatibility here. i believe the latest RTX 20xx graphics are supported
https://www.qnap.com/en/compatibility/
So has anyone gotten an RTX 20xx graphics card working with the new Nvidia driver update? I am looking at the 1660 ti for its HEVC B Frame Support. I see that QNAP Nvidia Driver is 2.1.3 but have no idea how this matches up to Nvidia's numbering scheme. It hasn't been updated as supported for the TS-877 in the compatibility tool, but I am not sure how frequently they update that.

Update1: I did find this on the Plex forums (though I am an Emby user :lol: ).
https://forums.plex.tv/t/qnap-ts-1677x- ... t/417297/9

"Likely will depend on what Nvidia driver version is required for Turing support.
For QTS 4.3.x, you are using Nvidia version 380’ish which I am pretty sure doesn’t support Turing.
The new QTS 4.4.1 beta upgrades the Nvidia driver version to 410.78.
So if Turing support needs newer than Nvidia driver 410.78, then you are out of luck right now. Also Turing functionality is kind of useless for most GPU uses in a NAS"

"Thanks, I’m on 4.4.1 currently but it looks like nvidia added support for the 1660 Ti with 418.43."

Update 2: I did also see in the earlier Driver update 2.0.0 that the "Nvidia Driver updated to 410.78" sort of confirming above. But that was 2019/03/28.
https://www.qnap.com/en-us/app_releasen ... IA_GPU_DRV
Last edited by scsherman on Sun Jun 16, 2019 1:42 pm, edited 1 time in total.

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9390
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: Nvidia Drivers

Post by Moogle Stiltzkin » Sun Jun 16, 2019 1:39 pm

scsherman wrote:
Sun Jun 16, 2019 1:24 pm
So has anyone gotten an RTX 20xx graphics card working with the new Nvidia driver update? I am looking at the 1660 ti for its HEVC B Frame Support. I see that QNAP Nvidia Driver is 2.1.3 but have no idea how this matches up to Nvidia's numbering scheme. It hasn't been updated as supported for the TS-877 in the compatibility tool, but I am not sure how frequently they update that.
Rumored Nvidia Super graphics card prices should lead to super price drops for current GeForce RTX 20-series cards


It seems the potential launch prices for the Super series are nothing out of the extraordinary for the Nvidia premium graphics cards. However, it wouldn’t make sense to keep the “old” GeForce RTX cards at similar prices as buyers would simply select the higher-specced Super cards. So, unsurprisingly, some price cuts are expected:

It can be opined that this is an odd strategy by Nvidia, to flood this end of the graphics card market with even more products that seem to only offer incremental increases to their non-Super brethren. It could even be argued that the green team should focus on the entry-level/midrange markets more, and perhaps even try to break into the console component market that AMD is currently dominating.
https://www.notebookcheck.net/Rumored-N ... 668.0.html
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

Post Reply

Return to “Official Apps”