DLNA not showing files

DLNA, AirPlay, Chromecast, PS3, XBOX, iTunes, & other media players
Ken81
Starting out
Posts: 11
Joined: Sat Jan 12, 2019 4:50 pm

Re: DLNA not showing files

Post by Ken81 » Sun Sep 22, 2019 9:05 pm

Just wanted to share that if you update the Plex version 1.16.6 with the manual pkg file, then the files will show in Plex :)

iok
Starting out
Posts: 34
Joined: Sun Jan 08, 2012 3:54 pm

Re: DLNA not showing files

Post by iok » Tue Sep 24, 2019 4:45 pm

I am experiencing the same issue with the new Multimedia Console and DLNA.
I have tried an hard reset of the database too, as described in https://www.qnap.com/en-us/how-to/knowl ... to-fix-it/. It did not work.
I guess that this is a bug. In Multimedia Content, under Content Management I can see that no audio/video/image has been included in Content Sources, even if thousand of them has been indexed and are visible under Overview. Still in Content Management I cannot see any "Edit" button or link to add folder containing multimedia files for the DLNA service. That is the issue, I guess.
I have opened a support request and I'm waiting for an answer.

Sibaq
New here
Posts: 3
Joined: Tue Sep 24, 2019 6:56 pm

Re: DLNA not showing files

Post by Sibaq » Tue Sep 24, 2019 7:37 pm

I am facing the exact same problem on my TS-231P.

Prior to 4.4.1 DLNA Server was streaming perfectly fine in all of my devices for the last 2 years; never had any problem with it besides minor issues here and there.
Yesterday I've run the 4.4.1 update after doing the recommended reboot before applying it.

After the update everything seemed to be working normally and then I've noticed that all the NEW content I've added AFTER the update was not appearing in the DLNA stream.
The folders are there but they appear to be empty.

I've restarted the Multimedia Services, the DLNA Server and the whole system several times to no avail.

My next step was to Re-index the database. Couple of hours later, not only the new but now ALL of the content is NOT appearing in the DLNA stream. Again, the folders are there but they appear to be empty.

After that I've tried a "Regenerate all Thumbnails" but since the DNLA server is not seeing any files no thumbnails can be re-generate or generate at all.

The Status on the Overview tab of the Multimedia Console reports:

Status
Monitor indexing and thumbnail generation for multimedia content.

Index Completed
Last update: 2019/09/24 14:02:03
Total files: 122970

Thumbnail Completed
Last update: Not Started
Total files: 0

Content Information
Contents
Photos:51749
Videos:6686
Music:64535

The Content Management tab reports:

Content Sources
Browse multimedia content in the following source locations using DLNA.

Content sources: 2
Used space:0 Bytes
Photos:0
Videos:0
Music:0


Please advice.

User avatar
dolbyman
Guru
Posts: 20516
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: DLNA not showing files

Post by dolbyman » Tue Sep 24, 2019 9:30 pm

report to qnap please..nothing we as users can fix

wilcal
Starting out
Posts: 35
Joined: Sun Nov 04, 2018 4:40 am

Re: DLNA not showing files

Post by wilcal » Wed Sep 25, 2019 4:11 am

Whew! It's not me. Since the last firmware update the DLNA server initially was not indexing new video files uploaded. Now it looks like there is no listing at all of files that are in there. So here's another user experiencing the same issue. I've tried lots of things all to no avail. Looking at the folders from an external computer using filezilla tells me the files, even the new ones, are in there. Downloading the files and I can play them using VLC.

Knock Knock QNAP!!!

wilcal
Starting out
Posts: 35
Joined: Sun Nov 04, 2018 4:40 am

Re: DLNA not showing files

Post by wilcal » Wed Sep 25, 2019 12:57 pm

Since the last firmware update the DLNA server initially was not indexing new video files uploaded. Now it looks like there is no listing at all of files that are in there. So here's another user experiencing the same issue. I've tried lots of things all to no avail. Looking at the folders from an external computer using filezilla tells me the files, even the new ones, are in there. Downloading the files and I can play them using VLC.

iok
Starting out
Posts: 34
Joined: Sun Jan 08, 2012 3:54 pm

Re: DLNA not showing files

Post by iok » Wed Sep 25, 2019 1:57 pm

Here is what Qnap support told me.
If I open the Multimedia Console, in the Overview panel I can see that there are many Photos, Video and Music files indexed but I cannot see them using a DLNA client.
If I open the Content Management panel, I have only DLNA there and under Content Sources nothing is selected and I can see that 0 files are available, that's why I cannot browse them using DLNA. Moreover there is not a link to Edit and Add content folders in Content Management panel for DLNA.

So, a Qnap support tech told me that this is by desing for the new Multimedia architecture in QTS 4.4.1. Only if you install the Video/Photo/Music Stations you can add Contents for them in Content Management panel and after you organize the files using the Stations app then you can see them with DLNA. You have to create a correct organization and some collections with the Stations otherwise you cannot see video, music or photos with DLNA in a good looking and usable way.
So it seems that, by new design, the Qnap embedded DLNA server is a passive interface that can only publish what is organized and configured with the Multimedia Stations Apps. It can no more work "alone".

I have installed Video Station and I created a basic collection and now I can see my videos using DLNA.

Maybe I will go back using Twonky Media server, as it was many QTS versions ago...

User avatar
dolbyman
Guru
Posts: 20516
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: DLNA not showing files

Post by dolbyman » Wed Sep 25, 2019 10:31 pm

that seems like a silly change..why would they cripple the dlna server that way?

I myself am exclusively using twonky and plex ...

mccormw
Getting the hang of things
Posts: 53
Joined: Sun Oct 09, 2011 7:38 pm

Re: DLNA not showing files

Post by mccormw » Thu Sep 26, 2019 4:49 pm

I use minimserver for music - which is absolutely fab. But I want to use the QNAP DLNA server for pictures & video (minim only does music), so I got caught with the same issue as iok - thanks for publishing that mate. Why could QNAP not inform us?
It seems that we get hit with similar issues each time there is a firmware update, perhaps I might stop doing auto updates and investigate a new update on these forums first.

Ken81
Starting out
Posts: 11
Joined: Sat Jan 12, 2019 4:50 pm

Re: DLNA not showing files

Post by Ken81 » Sat Sep 28, 2019 1:42 am

Happy to hear that people found solution on this, didnt know any others but me that bothered about this, so didn't check back on this thread for days. The tech guy at qnap that I contacted didn't tell me this at alll. He told me to keep letting the indexing go for 24-48 hrs even though the multimedia console says the indexing is complete, since apparently the indexing works in background even though it says completed..hm. By coincidence I discovered that installing Video Station solved the problem and replied back to them telling that this solved my problem. I do hope it wasn't my reply that made them aware of this solution and then offered it to you and others that contacted them after that :P If they did tell me at once, I would have saved 2-3 days researching it and coming across the solution by coincidence.

addiek
First post
Posts: 1
Joined: Mon Sep 30, 2019 7:22 pm
Location: Uddel, The Netherlands

Re: DLNA not showing files

Post by addiek » Mon Sep 30, 2019 7:50 pm

Just to let everyone know: I had the same issue as described by Sibaq, and I applied the resolution described by iok - thank you both.
Situation: DLNA with audio files of type 'flac' no longer visible in media controller (Linn Kinsky, Linn Kazoo) after installing 4.4.1, adding new audio content, and indexing.
Note: As long as you do'nt (1) add new audio content or (2) run indexing, everything works fine even after installing 4.4.1.
Resolution: Install Music Station, re-run indexing and everything will be back to normal. Also adding new audio content works fine again.

I suppose the QNap paradigma has been changed as follows: (1) If you want photo's being indexed (and visible on DLNA devices), you need to install Photo Station,
and (2) if you want audio files being indexed (and visible on DLNA devices), you need to install Audio Station, and so on for videos.
So you must install Audio Station even if you don't use Audio Station to listen to audio files directly form your NAS, which I never do since I only listen audio files using a media player (Linn Akurate).

For audio files, it was defenitely not required to install Audio Station before installing 4.4.1.
For audiophiles, it would be great if Qnap had given some clear recommandations and release notes to avoid all of us seeking for a resolution afterwards.
QNAP HS-453DX-4G

Sibaq
New here
Posts: 3
Joined: Tue Sep 24, 2019 6:56 pm

Re: DLNA not showing files

Post by Sibaq » Mon Sep 30, 2019 9:51 pm

I had to install the "Stations" as well in order for the DLNA server to read the database. The new management is i guess simpler for new builds and users but bad news for existing databases. Indexing and thumbnails took forever to re-build.

Krtek6
New here
Posts: 2
Joined: Tue Oct 01, 2019 7:09 pm

Re: DLNA not showing files

Post by Krtek6 » Tue Oct 01, 2019 7:19 pm

Hi all :!: I am dealing with this "invisible files" problem since friday. First I was like it was corrupt or someting, but than I have found this thread... So i had installed Video station and reindex all files. But my TV still wont see them. I am not sure if that 24-48hod reindex time has passed or is it neccesary....Can some please give me some tutorial (video will be great) for dummies? I am amateur home user. I have NAS only for DLNA and "backup" hdd. Thx for any advice and patience...

y0nza
First post
Posts: 1
Joined: Tue Oct 01, 2019 10:57 pm

Re: DLNA not showing files

Post by y0nza » Tue Oct 01, 2019 11:06 pm

Krtek6 wrote:
Tue Oct 01, 2019 7:19 pm
Hi all :!: I am dealing with this "invisible files" problem since friday. First I was like it was corrupt or someting, but than I have found this thread... So i had installed Video station and reindex all files. But my TV still wont see them. I am not sure if that 24-48hod reindex time has passed or is it neccesary....Can some please give me some tutorial (video will be great) for dummies? I am amateur home user. I have NAS only for DLNA and "backup" hdd. Thx for any advice and patience...
I was unable to make it work with all the stations installed either. Since my NAS is not exposed to outer world and is available only for internal network I gave up after few hours and simply downgraded firmware back to 4.3.6.1070 - works as before.

I think I will skip at least next 2-3 upgrades unless QNAP explains how this thing works now by writing decent tutorial.

Krtek6
New here
Posts: 2
Joined: Tue Oct 01, 2019 7:09 pm

Re: DLNA not showing files

Post by Krtek6 » Wed Oct 02, 2019 12:10 am

y0nza: hey man...I don´t know what I did, but I came home, start TV, open DLNA and everything is setup...it´s wierd....very wierd...last thing I did was shut down pc last night (30.9.2019 at 21:00) and went back now...and it was only indexing....and now? everything is setup....

but another question!! Some videos files are translated into Czech in TV. But every files I have on NAS are named by original TITLE.... One video is doubled in TV( I dont know why) and some has Thumbmail and some dont...

Post Reply

Return to “Media Streaming”