Can no longer access network drives.

Windows Access Rights Management
Post Reply
Tando
New here
Posts: 6
Joined: Sat Jun 17, 2017 11:18 pm

Can no longer access network drives.

Post by Tando » Sat Aug 01, 2020 1:46 am

I have 2 NAS, TS-832X and a TS-451A.

They both have the same problem since this last update, I can no longer access the shared drives from Windows.

When I try to go into them, where it would normally just ask me for the User&Pass and let me in, I get a pop up that says:

"An error occured while reconnecting N: to
\\NAS-TS-832X\Movies
Microsoft Windows Network: The local device name is already in use.

This connection has not been restored."


With only the option to hit Ok.

If I go into Qfinder I can see both of them on the list and I go into the details, config, recource monitor etc. just fine and can login to both through Firefox.

I disconnected one of the shared drives and tried to re-map it but that didn't work, when I every I try I have to enter the User&Pass and I get an error saying:

"Cannot log into the device shared folder. Please check the network connection or username and password, and make sure the device has been started."

I'm not the most technical when it comes to this unfortunately, so a couple reboots and trying to disconnect and re-connect are about as far as I can go with any confidence :?

Edit: Found that if I type the IP address of the NAS into Windows Broswer it will allow me into my files?
Edit2: Reseting the router does nothing, allows me to use it "normally" untill I need to restart the NAS then it just goes back to doing this stupid thing again.
Last edited by Tando on Sat Sep 19, 2020 4:53 pm, edited 2 times in total.

Tando
New here
Posts: 6
Joined: Sat Jun 17, 2017 11:18 pm

Re: Can no longer access network drives.

Post by Tando » Sat Aug 01, 2020 7:21 pm

The below worked but only temporarily, I had to reboot the NAS, now it has reverert back to not working and giving me the same error messages :(
  • Unmap all drives from Windows
  • Unpug the network cables from the back
  • Wait 30sec or so
  • Plug back in the Network cables
  • Then remap all shares through Qfinder

mbouraoui
First post
Posts: 1
Joined: Sat Aug 15, 2020 2:49 am

Re: Can no longer access network drives.

Post by mbouraoui » Sat Aug 15, 2020 3:00 am

Hey are you resolve your issue, I got the same issue ,please share thank.

Tando
New here
Posts: 6
Joined: Sat Jun 17, 2017 11:18 pm

Re: Can no longer access network drives.

Post by Tando » Sat Aug 15, 2020 3:07 pm

mbouraoui wrote:
Sat Aug 15, 2020 3:00 am
Hey are you resolve your issue, I got the same issue ,please share thank.
Unfortunately not, other than that temporary fix. I was suggested to reset my router instead of just unplugging the cable but I have not tried that yet.

If you can get it fixed please share, I will do the same.

Tando
New here
Posts: 6
Joined: Sat Jun 17, 2017 11:18 pm

Re: Can no longer access network drives.

Post by Tando » Thu Sep 24, 2020 11:59 pm

I got this issue fixed.

There was a couple things I was told to try but I will give you what worked for me first then add the rest at the bottom if you wish to read through it.

In Windows, add credentials for that share into the Windows Credential Manager:
a. Go to Control Panel > User Accounts > Manage Windows Credentials > Windows Credentials > Add a Windows Credential
b. For each NAS you wish to access, add in an entry for "\\NAS-[ServerName]" and a username and password (I used the details to log into the web GUI)

I have had no issues since adding the credentials for both my NAS.
|
|
The other troubleshooting that I tried that didn't seem to fix anything but I will add just incase they help others.

From the web GUI of the NAS go:

Control Panel > Network & File Services > Win/Mac/NFS > Microsoft Networking > Advanced Options
Set highest SMB version: SMB 3
Set lowest SMB version: SMB 1

On the same screen, try disable and re-enable the SMB service.
Disable "Enable file service for Microsoft networking" > click "Apply"
Then re-enable "Enable file service for Microsoft networking" > click "Apply". Make sure to set the correct Workgroup.

From Windows:

In Windows explorer, enter below (example), where NAS IP address is 10.5.10.105, shared folder name is share1:
\\10.5.10.105\share1
When prompted for user name, enter NAS-[ServerName]\admin, in below example NAS-[ServerName] is NAS-QNAP1, and user name is admin
NAS-QNAP1\admin

Use "net use" command in PC command line.
Press "Windows key+"R" > Type cmd > Click OK.
Then use the "net use" command (to verify current SMB connections).

Still in cmd, try to connect to NAS as per example below, again for example NAS IP address is 10.5.10.105, shared folder name is share1, NAS server name is NAS-QNAP1, and user account used to login is admin
net use \\10.5.10.105\share1 /user:NAS-QNAP1\admin
Enter admin password when prompted.

Errors might show here, I didn't get any so if you do get some you will have to investigate those.

Post Reply

Return to “Windows”