[HELP] Copy-paster error, file already exist

Windows Access Rights Management
Post Reply
aalbertiarch
First post
Posts: 1
Joined: Wed Oct 21, 2020 5:35 pm

[HELP] Copy-paster error, file already exist

Post by aalbertiarch » Wed Oct 21, 2020 5:51 pm

Hello everybody,

I have a problem that occurred after the last update of my QNAP TS-451+ firmware (version 4.5.1.1456)

When I copy past a file to the NAS, windows is alerting me that the file is already existing on the NAS and there is no such file already on the nas.
When you click "compare the files", the file that is on the NAS has 0 byte.
When you try to overwrite, a 0 byte file is created on the NAS.
When you rename locally the file to a name that can't exist on the NAS and retry to copy, the same alert is happening.

This happens
- after latest firmware update
- from file of local folder but also from another folder on the NAS
- with any type/size of file
- only with users having RW access to the folder even if the users account have RW access to the root and subfolders.

This doesn't happen
- with an admin account or group of users with more accesses (!!!)
- In FILESTATION on the admin account


This problem is really annoying and blocking my business (12 people working on the NAS)

THANK YOU FOR YOUR HELP!

fokkakuen
Starting out
Posts: 24
Joined: Thu Feb 28, 2019 3:39 pm
Contact:

Re: [HELP] Copy-paster error, file already exist

Post by fokkakuen » Thu Oct 22, 2020 3:22 pm

Hi, me too. i thing samba error . today i receive notice update to 4.5.1.1461 build 20201020 to fix " Non-administrator users could not copy files from one shared folder to another shared folder via SMB" . me so scared error again .
JVTECHCOM TOWNSON,MD HEADQUARTER

CHANGYANG VIETNAM MOLD SHOP CO,LTD

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Tue Oct 27, 2020 5:21 pm

I have the same problem !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :S :oops: :twisted:

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Tue Oct 27, 2020 8:03 pm

Further investigations showed, that the problem arrives only in that case, when any file is first copied from NAS to local disk, and then back - from the local to NAS!

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Wed Oct 28, 2020 5:44 pm

Raised the problem to QNAP support - they recommended to downgrade firmware to version 4.4.3.1439. I did, and the problem disappeared!

warnesj
New here
Posts: 6
Joined: Sat May 11, 2013 12:30 pm

Re: [HELP] Copy-paster error, file already exist

Post by warnesj » Sat Oct 31, 2020 5:21 am

I had the exact same problem on a client's TS-453A and the recent upgrade to 4.5.1.1465 Build 20201024 fixed it.

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Sat Oct 31, 2020 3:01 pm

I had the same problem on TS-251D with 4.5.1.1465 (do not remember build)!
The problem is quite strange:
Copy any file
PC->QNAP succeeds
any file
QNAP -> PC -> QNAP fails
the same file
QNAP->PC->Other NAS->PC->QNAP succeeds!

QNAP support acquired the problem and cascaded to dev team.

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9399
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: [HELP] Copy-paster error, file already exist

Post by Moogle Stiltzkin » Thu Nov 05, 2020 2:36 pm

1465 is the build. I tested this on a ts-877

tested copy from
- nas to pc - works


how i tested


i used a windows 10 desktop pc to access the share on the QNAP nas via file explorer. I then use the cut/copy which uses teracopy
https://www.codesector.com/teracopy
https://superuser.com/questions/1566851 ... ng-copying


I then confirm it worked by using a premade checksum file to confirm all the files are without issue.

how are u copying files over? are you using your desktop pc windows explorer? or are you using filestation?

fyi using admin default account
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

fokkakuen
Starting out
Posts: 24
Joined: Thu Feb 28, 2019 3:39 pm
Contact:

Re: [HELP] Copy-paster error, file already exist

Post by fokkakuen » Thu Nov 05, 2020 4:10 pm

PauLita wrote:
Wed Oct 28, 2020 5:44 pm
Raised the problem to QNAP support - they recommended to downgrade firmware to version 4.4.3.1439. I did, and the problem disappeared!
you firmware 4.5.1 1465 downgrade to 4.4.3.1439 ? downgrade system, data no any problem ?
JVTECHCOM TOWNSON,MD HEADQUARTER

CHANGYANG VIETNAM MOLD SHOP CO,LTD

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Thu Nov 05, 2020 4:54 pm

Yes, QNAP support advised and I downgraded to firmware version 4.4.3.1439. No problems. But sure, I DID HAVE a BACKUP!

Links:
[1] https://download.qnap.com/Storage/TS-X5 ... 3.1439.zip
[2] https://www.qnap.com/en-us/how-to/knowl ... -firmware/

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Thu Nov 05, 2020 5:38 pm

Today received the answer from QNAP support:

Verified on QTS 4.5.1 20201105 the result is PASS, Thanks!

Just going to check...

Yes, it hasn't been released yet. I would suggest for you to wait for a few days to few weeks.

fokkakuen
Starting out
Posts: 24
Joined: Thu Feb 28, 2019 3:39 pm
Contact:

Re: [HELP] Copy-paster error, file already exist

Post by fokkakuen » Fri Nov 06, 2020 12:03 pm

PauLita wrote:
Thu Nov 05, 2020 5:38 pm
Today received the answer from QNAP support:

Verified on QTS 4.5.1 20201105 the result is PASS, Thanks!

Just going to check...

Yes, it hasn't been released yet. I would suggest for you to wait for a few days to few weeks.
you using 4.5.1.1465 build 20201024, right ?
JVTECHCOM TOWNSON,MD HEADQUARTER

CHANGYANG VIETNAM MOLD SHOP CO,LTD

fokkakuen
Starting out
Posts: 24
Joined: Thu Feb 28, 2019 3:39 pm
Contact:

Re: [HELP] Copy-paster error, file already exist

Post by fokkakuen » Fri Nov 06, 2020 2:24 pm

PauLita wrote:
Thu Nov 05, 2020 4:54 pm
Yes, QNAP support advised and I downgraded to firmware version 4.4.3.1439. No problems. But sure, I DID HAVE a BACKUP!

Links:
[1] https://download.qnap.com/Storage/TS-X5 ... 3.1439.zip
[2] https://www.qnap.com/en-us/how-to/knowl ... -firmware/
i was downgrade back 4.4.3 is ok . Maybe i never update firmware on a long time. just wait forum to tolk about new firmware on the next time.
JVTECHCOM TOWNSON,MD HEADQUARTER

CHANGYANG VIETNAM MOLD SHOP CO,LTD

PauLita
New here
Posts: 9
Joined: Tue Oct 27, 2020 5:19 pm

Re: [HELP] Copy-paster error, file already exist

Post by PauLita » Tue Nov 10, 2020 10:34 pm

Today installed the newest firmware 4.5.1.1480. Problem disappeared.

Post Reply

Return to “Windows”