Cannot enable external FTP (TS-409 Pro / D-LINK DSL-G604T)

Windows Access Rights Management
Post Reply
samazary
New here
Posts: 3
Joined: Mon Oct 05, 2009 12:39 pm

Cannot enable external FTP (TS-409 Pro / D-LINK DSL-G604T)

Post by samazary » Mon Oct 05, 2009 12:59 pm

Hi I am having real trouble getting FTP access to my TS-409 Pro (latest v3 firmware). I have a fixed IP address and am using FileZilla for FTP and have the the D-LINK DSL-G604T wireless router which is supposedly excellent for port forwarding.

I have followed these instructions to enable FTP access (enabled DMZ to forward all ports to the NAS) but can't get it to work..
http://www.qnap.com/pro_features_ftp.asp

I get the FTP Error below:
Status: Connecting to **********...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error: Could not connect to server
Status: Waiting to retry...

Can someone please point me in the right direction or tell me what I am missing here?

jm45
Easy as a breeze
Posts: 411
Joined: Tue Oct 07, 2008 6:30 pm

Re: Cannot enable external FTP (TS-409 Pro / D-LINK DSL-G604T)

Post by jm45 » Mon Oct 05, 2009 10:02 pm

Hi,
How is set the security level of your NAS? (System Administration - Security)
TS-109 II firmware version: 3.1.0 Build 0708T (1TB disk)

samazary
New here
Posts: 3
Joined: Mon Oct 05, 2009 12:39 pm

Re: Cannot enable external FTP (TS-409 Pro / D-LINK DSL-G604T)

Post by samazary » Thu Oct 08, 2009 11:26 am

Hi its set to:
"Low: Allow all connections"

Any other ideas?

jm45
Easy as a breeze
Posts: 411
Joined: Tue Oct 07, 2008 6:30 pm

Re: Cannot enable external FTP (TS-409 Pro / D-LINK DSL-G604T)

Post by jm45 » Thu Oct 08, 2009 10:25 pm

Hi,
instead of dmz, try to portforward 21 & pasv ports.
TS-109 II firmware version: 3.1.0 Build 0708T (1TB disk)

samazary
New here
Posts: 3
Joined: Mon Oct 05, 2009 12:39 pm

Re: Cannot enable external FTP (TS-409 Pro / D-LINK DSL-G604T)

Post by samazary » Fri Oct 09, 2009 5:12 am

Done. FTP access now works like a dream thanks for your help...

Get the info from this article on the D-LINK DSL-G604T from D-Link http://www.dlink.com.au/tech/Default.asp

How to open ports

Step 1. Before you open ports in your router, set the computer (or the device) which requires ports to be opened for, with a static IP address. You can choose any IP address from the range of addresses you are using on your local network, as soon as it is not used by any other device. The default range is from 10.1.1.2 to 10.1.1.254. In our example we are using 10.1.1.99.

Windows XP: Control Panel > Network Connections > Local Area Connection > Properties > Internet protocol TCP/IP > Properties
Windows Vista: Control Panel > Network and Internet > [Network and Sharing Centre] > View Network Status and Tasks > View Status > Properties > Internet Protocol v4 > Properties

Select the 'Use the following IP address' option:
IP address: 10.1.1.99
Subnet mask: 255.0.0.0
Default Gateway: 10.1.1.1 (your router's address)
DNS: 10.1.1.1 and 61.88.88.88 (or whichever your provider is using)

Step 2. Open your web browser and enter the IP address of the router (http://10.1.1.1). Enter user name and password (default username 'admin' and password is 'admin').

Step 3. Click on Advanced at the top and then click on LAN Clients.

Step 4. You will need to add a LAN Client (the address of your computer or a device) into the router before you can open any ports. Type in the IP address of the Computer/Device (the one you assigned in Step 1). You can specify the name of this workstation under Host Name (optional). Click Add and then Apply.

Step 5. Go to Advanced > Virtual Server (Port Forwarding). There is a list of pre-set ports in the router which you can choose from.

Step 5a. If your specific application is not listed there, you can add the necessary ports yourself. Select the 'User' Category and click on Add button below.

Step 5b. Enter a name for this entry under Rule Name. Then select the necessary protocol. If there is a range of ports to open, specify the starting port under Port Start and the ending port under Port End. If you need to open just one port, specify this port number in all fields including the Port Map. Click Apply.

Step 6. Go back to Advanced > Virtual Server. Under LAN IP select your LAN Client (which you added in Step 4). Select the Category and the desired Rule or select 'User' Category and you should see the rule which you have created in Step 5b. Select it and then click on Add > to move it into the Applied Rules section. Click Apply.

Step 7. To save the new settings into the router's memory go to Tools > System. Click on Save and Reboot button. The router will save the settings and restart.



Note 1: If you are opening ports for FTP, Telnet or other service, please make sure this service is not additionally blocked by the router's firewall. You can verify this under Advanced > Firewall > Service Filtering.

Note 2: Because routers use NAT (Network Address Translation), you can only open a specific port to one computer at a time. For example: If you have two Web servers on your network, you cannot forward port 80 to both computers. You will need to configure one of the web servers to use port 81. Now you can forward port 80 to the first computer and then forward port 81 to the other computer.

Note 3: Please be aware that from inside your LAN you will not be able to access your server using its public IP address or name. On your LAN you will need to use its local IP address instead (10.1.1.99).

Note 4: It is quite common for Internet Service Providers to block common ports like 80, 21, 25. If you are having troubles running services on these ports please contact your provider.

Post Reply

Return to “Windows”