Cannot get FTP to work on 109II 3.1.0 Build 0708T

Windows Access Rights Management
Post Reply
akim
New here
Posts: 2
Joined: Mon Oct 13, 2008 9:48 pm

Cannot get FTP to work on 109II 3.1.0 Build 0708T

Post by akim » Tue Oct 06, 2009 4:08 pm

I have enabled FTP Service in Qnap and made port forwarding of 21 and 22 in my router but i cannot get FTP to work. I have tried Windows Explorer, Filezilla and Classic FTP - the operation timeout. Qnap system log says login ok! Does this mean that port forwarding 21 is working or can the problem be me router?

QNAP System log:
Date Time Users Source IP Computer name Connection type Accessed resources Action
2009-10-06 09:56:39 mary 81.215.59.226 --- FTP --- Login OK


Thanks in advance
Akim

jm45
Easy as a breeze
Posts: 411
Joined: Tue Oct 07, 2008 6:30 pm

Re: Cannot get FTP to work on 109II 3.1.0 Build 0708T

Post by jm45 » Tue Oct 06, 2009 7:04 pm

Hi,
did you
-portforward in your router the passive port range set in your NAS for FTP?
-and check "Respond with external IP address for passive FTP connection request"

Unless from client side, implicit passive mode asked will time-out after PASV command.
BTW,you may test "active mode" too from your client configuration.
TS-109 II firmware version: 3.1.0 Build 0708T (1TB disk)

akim
New here
Posts: 2
Joined: Mon Oct 13, 2008 9:48 pm

Re: Cannot get FTP to work on 109II 3.1.0 Build 0708T

Post by akim » Wed Oct 07, 2009 2:13 pm

Thank you Silver Warrior jm45 - it helped!

Now I have learned about active and passive FTP. As you said, I had to forward (in my router) the "Passive FTP Port Range" defined in QNAP and check "Respond with external IP address for passive FTP connection request" in QNAP.

I did not test active mode.

Thanks again.
Akim

Post Reply

Return to “Windows”