Virtual machines not starting anymore

QNAP NAS solution for server virtualization and clustering/HA/FT
Post Reply
First post
Posts: 1
Joined: Tue Jul 07, 2020 9:24 pm

Virtual machines not starting anymore

Post by d_else01 » Tue Jul 07, 2020 9:58 pm

Short story:

1) I have a TVS-473e with several VMs that have their virtual HDDs on a M.2-SSD (connected via a QM2-2P-384) that suddenly (about 2-3 months ago) stopped working. They cannot be started (gives an Error: "An Exception has occured (2).") anymore. Setting up a new VM with its HDD on the same location can be booted untill you access the Hard-drive (e.g. partitioning in a OS-install). VMs with HDD-images on other storage can boot and/or install a new OS.

2) is there some way to get an internal ticket in the qnap-support "escalated"? I have a supporter who is obviously not willing to help me with my problem and there seems to be completely no way to get to talk to somebody else.

Long story (maybe somebody can give me some help advancing here):

I noticed the described problem a few months ago (the VMs are not THAT necessary for me - but i wil need them back at some point). Also at this point the file-system was only readable - i couldnt even create files via SSH on that pool. I opened a ticket in the support portal and the supporter asked me for a log-dump.
When i provided this, he complained i have "not supported" RAM ( 2x 16 GB crucial CT8G4SFS824A - crucial lists this as "100% guranteed compatible: ... ct14388541), but also told me to "simply let the system check the file system". I had done this before with no success but this time it worked and the file-system was accessible again. When i asked him about the VMs, the answer i got was: "we only solve one problem per ticket - your filesystem is accessible again. open a new Ticket for the VMs".

Seriously - at this point i was so frustrated i gave up on it for a few weeks before i opened the new ticket. And i immedeately got the answer "you have not supported ram in your system - i wil not help you". Even when i tested myself that machines with their images on other storage boots do work, so he agreed with me on that the problem is not related to my RAM (i am currnetly in contact with crucial, too to get help this way - they guarantee compatibility and i dont get support when i have their modules installed?) he still refuses to elp me analyse or fix my problem.

I tried to boot the system only with the 4GB that it came with, but i cant boot a VM with only 4GB installed. And now i send a log with only the original RAM to the support and he is even telling me "these are not supported, too" (i bought the device at amazon - seller was the official QNAP account). I had to send him a photo of the modules. And now he wants me to:

1) run memory tests
2) get a new testing-HDD, set up a new system and boot up a completely empty vm (which i cant woith the official RAM - so i would have to buy a supported module - which costs 5x the amount of what i paid for the memory i have)

And all this is still only to get him to look at my problem.
When i asked him to check if this configuration is supported anyway (if it isnt, why continue all this madness) he answers: "new question - new ticket" (opened that - till now no answer)
When i asked, if there is a way to release some more memory so i could start a VM with only the original 4GB (which arent satisfiing for him, too, obvously): "new question - new ticket" (opened that - till now no answer)

This is so unbeliably frustrating. This is going on for months now and we didnt even start to lok at my initial problem. And all i can do is: "open another ticket". I have to do with a lot of supporters in my professional life but i never experienced something like this. I am technically not completely unexperienced but i dont have enough knowledge to debug and/or fix this by myself. So if anyone could provide some help in either solving my problem or giving me tips on how i could get help the official way i would be very thankful.

Post Reply

Return to “Server Virtualization & Clustering”