[CLOSED] Lost access to shares

Questions about using Windows AD service.
Post Reply
New here
Posts: 3
Joined: Mon Mar 09, 2020 3:09 am

[CLOSED] Lost access to shares

Post by jameskody » Tue Mar 24, 2020 8:11 am

UPDATE: This issue is not solved in that I do not know what caused the problem in the first place but I am back up and running. I called QNAP Support and had a remote session with them. We ended up with a work-around rather than a solution.

Create a new share, use File Station to copy the data and then apply permissions to the new share. I will need to update a few client machines to point to the new share name but I can script that -- no biggie.

Ok, for the second time this month, this NAS is giving me fits. I have lost access to several shares --- some, but not all. When I try to access them, I get an error.

Windows cannot access \\ip\share
You do not have permission to access \\ip\shae. Contact your administrator ... blah blah blah (attachment 1)

When try to view the Security tab of the share from the Win 10 client, it says I need Read permissions. I have tried using the Advanced menu to take ownership, but that is failing. See attachment 2.

I am unable to view the current owner. See attachment 3.

One thing that is interesting - but I am not sure if it is relevant - is shares that I can access show a red X for Administrator on the Security tab. See attachment 4.

Within Share Manager, Domain Users have R/W access to the share. See attachment 5.

My username (kody\jim) is a member of the Domain Users group. See attachment 6. I also tried granting kody\jim Domain Admin perms -- no joy.

I am able to browse the data in File Station.

Is there way to reset permissions, recursively, from the root of the share? I am dead in the water here without access to my data. I do have a backup from 20 Mar. There were a few changes on 21 Mar and I know what those changes are and those were copied off to another USB in case I need to wipe this device or god forbid, this NAS accidentally falls out of the 12th floor window.

TIA for any assistance or guidance.
You do not have the required permissions to view the files attached to this post.
Last edited by jameskody on Wed Mar 25, 2020 9:18 am, edited 1 time in total.

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 8961
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....

Re: Lost access to shares

Post by Moogle Stiltzkin » Tue Mar 24, 2020 3:12 pm


so i am assuming you are using windows 10 and have the QNAP connected to your on the same lan network?

To connect to the qnap

1. in windows 10 go to credential manager and add your qnap device name or lan ip and credentials. so you don't have to re-enter it everytime you can save credential

2. other option is to enable guest access in qts. i rather go with option 1, so anyone that can connect to the qnap MUST have credentials to access.

Make sure that your QNAP NAS lan ip is static. If your lan ip isn't static, there is a possibility that each them you reboot, the lan ip changes, which could explain why that path to that lan ip is no longer valid. it's a possibility. you didn't quite explain your setup, so i am merely speculating at this point due to lack of info on this.

In qts under shares, there is permission and access rights for your user accounts. Check that the settings for that is correct. If you are very restrictive, so of course some stuff will have issues when trying to access. Usually the defaults work perfectly fine. But if you are tweaking around with those settings, make sure you set them correctly.
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) single disks.
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228
[^] QNAP TS-128
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)

Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

New here
Posts: 3
Joined: Mon Mar 09, 2020 3:09 am

Re: Lost access to shares

Post by jameskody » Wed Mar 25, 2020 3:19 am

I tried the instructions in viewtopic.php?t=61597#p278290 // no change

Option 1) Why would I need to add a credential when this is already / still working for some shares? I need to understand what permissions changed on the shares that are no longer working and fix those.
Option 2) Errrm ... no.

NAS IP is static
Clients get a DHCP address from the router
NAS and clients are in the same subnet

Guess access: Deny

Permissions for the shares are "DOMAIN\Domain Users: R/W". This is true of shares that I can access and shares that I cannot access. I am logging on with a user account that is a member of the Domain Users group.

First post
Posts: 1
Joined: Mon Jun 29, 2020 9:26 am

Re: [CLOSED] Lost access to shares

Post by bbcala » Mon Jun 29, 2020 9:43 am

I have the same issue,

one day, update NAS fireware and Windows10 update then this happen always occur
and I need to remove the credential before shut down PC
because the credential message box will pop-up again after reboot

in my case, using \\172.xx.xx.xx must need to remove credential before shut down
when using \\NASxxxx still occur but much less than using \\IP

I can't change to use \\NASxxxx because some software must use the \\IP

Post Reply

Return to “Windows Domain & Active Directory”