[SOLVED] AFP wont work ;(((

Questions about using NAS on Mac OS.
User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: AFP wont work ;(((

Post by schumaku » Sat Aug 17, 2013 8:02 pm

jdelaney78 wrote:There's no need to be rude. ...
Asking the posters on versions is absolute valid - as the community forum content has a long life, and remains as a reference for years. It's indeed true that "latest version" can vary widely: There are Beta versions in the field, there are closed Beta releases made available illegally on some regional fora, there are special version builds for markets with strong regulations, version available to download from the forum, same releases slightly delayed intentionally to the www.qnap.com download, and delayed intentionally again to the Live Update availability, ...

hggnoo
New here
Posts: 2
Joined: Tue Jan 14, 2014 8:04 am
Location: Netherlands

Re: [SOLVED] AFP wont work ;(((

Post by hggnoo » Tue Jul 22, 2014 1:45 am

@MarB: Thanks. Deleting the files:
.AppleDB
.AppleDesktop
.AppleDouble
worked for me; AFP connection is working again.
Note: when searching with Web File Manager, make sure you have 'show hidden files' in QNAP settings switched on.
Note: deleting these files using Telnet, see http://wiki.qnap.com/wiki/How_to_remove_.AppleDB_for_the_share_with_problem%3F

jefftee
Starting out
Posts: 22
Joined: Sun Jan 31, 2016 12:48 pm

Re: [SOLVED] AFP wont work ;(((

Post by jefftee » Tue Feb 23, 2016 8:39 am

My AFP access is restored after deleting the following directories from all shares on my TVS-871T:

.AppleDB
.AppleDesktop
.AppleDouble

Thanks to those that posted the solution, it was very frustrating trying to figure this out until I ran across this thread!

mickatl
New here
Posts: 3
Joined: Mon Nov 02, 2015 11:44 pm

Re: [SOLVED] AFP wont work ;(((

Post by mickatl » Thu Feb 25, 2016 8:09 am

Have you figured out what is causing the macs to create those directories? I'm having issues with AFP being unreliable. The server is broadcast (bonjour) to the macs with servername(AFP) & servername(AFP(Thunderbolt) but when I try to open them on any of the 3 macs we have, sometimes they open and other times not.

jefftee
Starting out
Posts: 22
Joined: Sun Jan 31, 2016 12:48 pm

Re: [SOLVED] AFP wont work ;(((

Post by jefftee » Thu Feb 25, 2016 10:29 am

They are all created as part of the netatalk (AFP) protocol. Here's an explanation of these files (and more). I don't, however, know why these directories may cause AFP from working, but after removing all I was able to subsequently access my shares via AFP again.

pbart
Know my way around
Posts: 102
Joined: Thu Feb 28, 2013 12:36 am

Re: AFP wont work ;(((

Post by pbart » Fri Sep 25, 2020 3:44 pm

I think I'm experiencing the very same problem. Won't connect the NAS with AFP, but works with NFS...

Where can I find the files below ? Are they in the root directory of the NAS volume ?
MarB wrote:
Fri May 10, 2013 1:16 am
After I deleted all Files/directories named:

.AppleDB
.AppleDesktop
.AppleDouble

On all shares, more than 5k

Restarted Afp, and it Works again.....
Paolo Bartoli
----------------
Mac OS X 10.14
QNAP TS251 + QNAP TS219PII
QTS 4.3.3

pbart
Know my way around
Posts: 102
Joined: Thu Feb 28, 2013 12:36 am

AFP wont work

Post by pbart » Wed Sep 30, 2020 5:07 pm

I'm still experiencing problems with Mac OS AFP connection to my TS-219P II NAS, running QTS 4.3.3.1386 (latest release AFAIK).

I tried deleting
.AppleDB
.AppleDesktop
.AppleDouble
as suggested, restarted AFP and rebooted, but still AFP doesn't work.

What should I look for ?

What is puzzling me is that I can access the NAS from the web address, but not from Mac OS Finder...
Paolo Bartoli
----------------
Mac OS X 10.14
QNAP TS251 + QNAP TS219PII
QTS 4.3.3

pbart
Know my way around
Posts: 102
Joined: Thu Feb 28, 2013 12:36 am

Re: AFP wont work

Post by pbart » Wed Sep 30, 2020 5:09 pm

BTW, I also get errors notification like these:

"Server Name: QNAPxNAS
IP Address: 192.168.2.2
Date/Time: 2020/09/30 10:58:25
Level: Warning
[Antivirus] Failed to update virus definitions. Please try again later or update the definitions manually."

Seems like the NAS itself is unable to connect properly to the web to update virus definitions.

Any clue?
Thanks
pbart wrote:
Wed Sep 30, 2020 5:07 pm
I'm still experiencing problems with Mac OS AFP connection to my TS-219P II NAS, running QTS 4.3.3.1386 (latest release AFAIK).

I tried deleting
.AppleDB
.AppleDesktop
.AppleDouble
as suggested, restarted AFP and rebooted, but still AFP doesn't work.

What should I look for ?

What is puzzling me is that I can access the NAS from the web address, but not from Mac OS Finder...
Paolo Bartoli
----------------
Mac OS X 10.14
QNAP TS251 + QNAP TS219PII
QTS 4.3.3

pbart
Know my way around
Posts: 102
Joined: Thu Feb 28, 2013 12:36 am

Re: [SOLVED] AFP wont work ;(((

Post by pbart » Wed Sep 30, 2020 5:29 pm

I also noticed that NFS connection works fine...
Paolo Bartoli
----------------
Mac OS X 10.14
QNAP TS251 + QNAP TS219PII
QTS 4.3.3

torch1
Know my way around
Posts: 103
Joined: Thu Jul 04, 2019 4:53 am

Re: [SOLVED] AFP wont work ;(((

Post by torch1 » Thu Oct 01, 2020 6:29 am

Development on AFP stopped at Mac OSX 10.8 - it is basically deprecated in favor of SMB, which has continued to evolve (latest in 10.15). https://support.apple.com/en-us/HT210803
If you haven't yet, I suggest you disable AFP on the QNAP. No issues that I have seen with SMB including Time Machine over SMB.

pbart
Know my way around
Posts: 102
Joined: Thu Feb 28, 2013 12:36 am

Re: [SOLVED] AFP wont work ;(((

Post by pbart » Thu Oct 01, 2020 5:21 pm

torch1 wrote:
Thu Oct 01, 2020 6:29 am
Development on AFP stopped at Mac OSX 10.8 - it is basically deprecated in favor of SMB, which has continued to evolve (latest in 10.15). https://support.apple.com/en-us/HT210803
If you haven't yet, I suggest you disable AFP on the QNAP. No issues that I have seen with SMB including Time Machine over SMB.
Thanks torch1 for this information.

I just checked and the connectivity problem persist with SMB also, while it works with NFS, go figure why.

What might cause SMB to fail while NFS works ?
Paolo Bartoli
----------------
Mac OS X 10.14
QNAP TS251 + QNAP TS219PII
QTS 4.3.3

torch1
Know my way around
Posts: 103
Joined: Thu Jul 04, 2019 4:53 am

Re: [SOLVED] AFP wont work ;(((

Post by torch1 » Thu Oct 01, 2020 9:39 pm

Not sure why SMB fails, but if your network is local only, you could limit the type of connections by creating a config file:
sudo nano /etc/nsmb.conf
<password>

Code: Select all

[default]
signing_required=no
protocol_vers_map=6
port445=no_netbios
streams=yes
ctrl-O
ctrl-X

This will disable signing, limit SMB protocol to SMB2+, ignore netbios and enable streams.
For Time Machine, follow the QNAP tutorial https://www.qnap.com/en-us/how-to/tutor ... s-via-smb/

Post Reply

Return to “Mac OS”