[ Home Assistant ] [ 0.109.6 ] Open-source home automation platform

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

[ Home Assistant ] [ 0.109.6 ] Open-source home automation platform

Post by QNAP_Stephane » Sun Mar 20, 2016 2:50 am

Image

Source : https://home-assistant.io

Download :

https://www.qnapclub.eu/fr/qpkg/299


About :

Home Assistant will track the state of all the devices in your home, so you don't have to.

Control all your devices from a single, mobile-friendly, interface.
Home Assistant allows you to control all your devices without storing any of your data in the cloud. We like to keep your privacy private.

Set up advanced rules to control devices and bring your home alive.

Do you want to …

have the lights turn on when the sun sets and you are home?
have the lights turn on when anyone comes home and it is dark?
dim the lights when you start watching a movie on your Chromecast?
receive a message when the lights turn on while you are not at home?


Image

---- Dev info ---

listen on 8123
config / logs and DB = /opt/Home-Assistant/CONFIG_DIR
Last edited by QNAP_Stephane on Mon May 18, 2020 1:06 am, edited 5 times in total.
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

rvt
New here
Posts: 5
Joined: Fri Jul 06, 2012 2:55 am

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by rvt » Sun Apr 17, 2016 6:58 pm

Thank's I'll test asap

Atrejoe
Getting the hang of things
Posts: 65
Joined: Wed Nov 14, 2012 11:04 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by Atrejoe » Sun May 15, 2016 5:36 am

Is it also possible to build in the architecture of my TS-410? (as it's stating x86 is not compatible, it should have x64).

If this is any hassle for you, skip it, I'm just browsing :)

I already installed python, but installing PIP seemed a bit too much, when I encountered your post.

Nieldm
Starting out
Posts: 10
Joined: Sun Aug 02, 2015 8:07 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by Nieldm » Mon Aug 15, 2016 12:54 am

I just found this and I have to say it is a fantastic addon, very many thanks indeed. Apologies for the minor cross-post, i initially posted in the modderz forum, but realised this is a better place.

I am trying to enable the Amazon Echo integration, which requires the installation of the Amazon CLI (awscli) but I am struggling to get it installed, neither pip install nor the install from the downloaded package are working, although both seem to install correctly. Here's the output of the pip install, but you will see that aws is subsequently not found.

Any thoughts or advice would be really helpful....

Marc

[~] # pip install awscli --upgrade -t /share/MD0_DATA/aws --trusted-host pypi.python.org -b /share/MD0_DATA
Collecting awscli
Downloading awscli-1.10.56-py2.py3-none-any.whl (986kB)
100% |████████████████████████████████| 987kB 3.5MB/s
Collecting botocore==1.4.46 (from awscli)
Downloading botocore-1.4.46-py2.py3-none-any.whl (2.5MB)
100% |████████████████████████████████| 2.5MB 4.2MB/s
Collecting s3transfer<0.2.0,>=0.1.0 (from awscli)
Downloading s3transfer-0.1.1-py2.py3-none-any.whl (49kB)
100% |████████████████████████████████| 49kB 3.5MB/s
Collecting rsa<=3.5.0,>=3.1.2 (from awscli)
Downloading rsa-3.4.2-py2.py3-none-any.whl (46kB)
100% |████████████████████████████████| 49kB 3.4MB/s
Collecting colorama<=0.3.7,>=0.2.5 (from awscli)
Downloading colorama-0.3.7-py2.py3-none-any.whl
Collecting docutils>=0.10 (from awscli)
Downloading docutils-0.12.tar.gz (1.6MB)
100% |████████████████████████████████| 1.6MB 4.0MB/s
Collecting jmespath<1.0.0,>=0.7.1 (from botocore==1.4.46->awscli)
Downloading jmespath-0.9.0-py2.py3-none-any.whl
Collecting python-dateutil<3.0.0,>=2.1 (from botocore==1.4.46->awscli)
Downloading python_dateutil-2.5.3-py2.py3-none-any.whl (201kB)
100% |████████████████████████████████| 204kB 4.0MB/s
Collecting futures<4.0.0,>=2.2.0 (from s3transfer<0.2.0,>=0.1.0->awscli)
Downloading futures-3.0.5-py2-none-any.whl
Collecting pyasn1>=0.1.3 (from rsa<=3.5.0,>=3.1.2->awscli)
Downloading pyasn1-0.1.9-py2.py3-none-any.whl
Collecting six>=1.5 (from python-dateutil<3.0.0,>=2.1->botocore==1.4.46->awscli)
Downloading six-1.10.0-py2.py3-none-any.whl
Installing collected packages: jmespath, six, python-dateutil, docutils, botocore, futures, s3transfer, pyasn1, rsa, colorama, awscli
Running setup.py install for docutils
Successfully installed awscli-1.10.56 botocore-1.4.46 colorama-0.3.7 docutils-0.12 futures-3.0.5 jmespath-0.9.0 pyasn1-0.1.9 python-dateutil-2.5.3 rsa-3.4.2 s3transfer-0.1.1 six-1.10
[~] # aws
-sh: aws: command not found
[~] #

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by QNAP_Stephane » Mon Aug 15, 2016 4:49 pm

you use pip from HomeAssitant/bin i suppose

may be this one is not in your $PATH, did you check inside /share:MD0_DATA/aws (or may be in /opt/HomeAssistant ) ?

you can look for it with : find / -name awscli
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

Tomek985
New here
Posts: 6
Joined: Mon Sep 12, 2016 1:02 am

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by Tomek985 » Mon Sep 12, 2016 1:26 am

I want to send big thanks to QNAP_Stephane for this setup.
Worked nicely out of the box. And everything was build nicely with auto-update that required almost no maintenance.

However, I wonder if it is possible to re-release the package with latest python 3.5 and HA. Since I have x86_64 QNAP, I was able to get Open Z-wave working as well (somewhat), but in process screwed up the HA package (now relying mostly on Entware-NG)

mechanimal82
Know my way around
Posts: 136
Joined: Thu Feb 10, 2011 10:20 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by mechanimal82 » Wed Dec 14, 2016 10:32 pm

Seems discovery is not working (at least for me). Below is shown in the log:

16-12-14 14:22:33 homeassistant.util.package: Attempting install of netdisco==0.7.7
16-12-14 14:22:53 homeassistant.bootstrap: Not initializing discovery because could not install dependency netdisco==0.7.7
16-12-14 14:22:53 homeassistant.core: Bus:Handling <Event call_service[L]: service_data=message=The following components and platforms could not be set up:
* discovery

is there a way to manually install this or include as part of the package?

Details on the HA site here: https://home-assistant.io/components/discovery/

If you see Not initializing discovery because could not install dependency netdisco==0.6.1 in the logs, you will need to install the python3-dev or python3-devel package on your system manually (eg. sudo apt-get install python3-dev or sudo dnf -y install python3-devel). On the next restart of home-assistant, discovery should work. If you still get an error, check if you have a compiler (gcc) available on your system.


I've tried installing python dev via opkg and then changing the python directory in the Home-Assistant.sh file, but no luck. Any help would be appreciated.

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by QNAP_Stephane » Wed Dec 14, 2016 10:38 pm

may be due to an automatic update

try : /opt/Home-Assistant/bin/pip install netdisco

if it require a gcc it will not install, but may be a luck
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

mechanimal82
Know my way around
Posts: 136
Joined: Thu Feb 10, 2011 10:20 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by mechanimal82 » Wed Dec 14, 2016 10:44 pm

Hmmm..

[~] # /opt/Home-Assistant/bin/pip install netdisco
Requirement already satisfied: netdisco in /share/CACHEDEV1_DATA/.qpkg/Home-Assistant/lib/python3.4/site-packages
Requirement already satisfied: zeroconf>=0.17.4 in /share/CACHEDEV1_DATA/.qpkg/Home-Assistant/lib/python3.4/site-packages (from netdisco)
Requirement already satisfied: requests>=2.0 in /share/CACHEDEV1_DATA/.qpkg/Home-Assistant/lib/python3.4/site-packages (from netdisco)
Requirement already satisfied: netifaces in /share/CACHEDEV1_DATA/.qpkg/Home-Assistant/lib/python3.4/site-packages (from zeroconf>=0.17.4->netdisco)
Requirement already satisfied: enum-compat in /share/CACHEDEV1_DATA/.qpkg/Home-Assistant/lib/python3.4/site-packages (from zeroconf>=0.17.4->netdisco)
Requirement already satisfied: six in /share/CACHEDEV1_DATA/.qpkg/Home-Assistant/lib/python3.4/site-packages (from zeroconf>=0.17.4->netdisco)

Could it be that because HA uses Python 3 - we need to use pip3?

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by QNAP_Stephane » Thu Dec 15, 2016 12:42 am

may be have a try with pip3 but think i symlinked pip to pip3
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

mechanimal82
Know my way around
Posts: 136
Joined: Thu Feb 10, 2011 10:20 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by mechanimal82 » Thu Dec 15, 2016 3:10 am

Pip3 natively didn't work. I'm afraid that's pushing the limits of my knowledge now, not sure how best to simlink pip to pip3.

Thanks for your help by the way!

Sent from my HTC One M9 using Tapatalk

markr71
Starting out
Posts: 31
Joined: Sun Aug 21, 2016 2:41 am

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by markr71 » Wed Dec 28, 2016 10:35 pm

Hello, I'm looking to move my HA from my laptop to the QNAP and found this and thought - ah brilliant. but I have the same problem, cannot get discovery to run. Does anyone have any ideas at all please?

Cheers
Mark

goodelyfe
Know my way around
Posts: 122
Joined: Tue Jul 01, 2014 5:50 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by goodelyfe » Fri Dec 30, 2016 4:34 pm

yea same error for me as well.

Code: Select all

Invalid Config 

The following components and platforms could not be set up:

- discovery

Please check your config

ed661266
First post
Posts: 1
Joined: Sat Apr 11, 2015 2:29 pm

Re: [ Home Assistant ] [ 0.15.0 ] Open-source home automation platform

Post by ed661266 » Sat Jan 21, 2017 4:38 pm

I was able to get discovery running by:

1. Install Entware-ng from https://github.com/Entware-ng/Entware-ng/wiki/Install-on-QNAP-NAS
2. Install

Code: Select all

gcc


via

Code: Select all

opkg install gcc


3. Run

Code: Select all

pip3 install netdisco


(netdisco has a netifaces dependency which requires gcc)

4. Restart home assistant

NOTE: I am very new to HA and QNAP package installation and was able to get this working via pure trial and error, YMMV

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Home Assistant ] [ 0.36.1 ] Open-source home automation platform

Post by QNAP_Stephane » Sun Jan 22, 2017 2:48 am

updated with bug fixed (netdisco), added latest Python libs dependency
all libs updated with Python 3.6 as backend
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

Post Reply

Return to “Community Apps”