[ NextCloud ] [ 20.0.1.0] OwnCloud Fork

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by QNAP_Stephane » Thu Oct 03, 2019 2:41 pm

No sure to really understand... Qapache do not use phpfpm ...

if you want tweak Nextlcoud webserver config as explain it is within the httpd.conf embedded inside /opt/Nextcloud
if you want adjuste php setting the php.ini used is the one of Qapache /opt/Qapache/etc/conf/php.ini

i actually have no clue if it is memory leak or somethin else... seems httpd sokets are not released when disconnection from client happen (on what i understand)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

nickdanp
New here
Posts: 4
Joined: Sun Jul 23, 2017 4:56 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by nickdanp » Fri Oct 04, 2019 12:10 am

Thanks for the pointers. I'll keep digging - suspect httpd.conf inside /opt/Nextcloud is where I need to go. Hope so, as I've accidentally borked my installation fiddling around in there! Ho hum, allows me to set up properly from scratch at least...

kobe
Starting out
Posts: 31
Joined: Wed Jan 27, 2010 8:46 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by kobe » Mon Oct 07, 2019 7:25 am

Just to confirm. Same problem here. NextCloud started clogging up a lot of memory recently (first noticed three days ago before upgrading to 17.0.0). Again 10 Minutes ago.
  • QNAP TVS-663 with 16GB
  • NextCloud httpd services accumulated more than 10GB of memory
Have both current versions of QApache & NextCloud installed. When this happens, QNAP becomes slow up to the point, where I could not log-in anymore.

mitch569
New here
Posts: 9
Joined: Thu May 02, 2019 6:36 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by mitch569 » Mon Oct 07, 2019 9:02 am

Yes it it quite strange.
i have played around with some settings in qapache php.ini and haven't had much luck.
Good to hear I haven't been the only one :lol:

Could it possibly be something to do with the httpd-ssl.conf settings?

I don't believe I have changed many settings other than what is required.

nickdanp
New here
Posts: 4
Joined: Sun Jul 23, 2017 4:56 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by nickdanp » Tue Oct 08, 2019 1:09 am

Still no luck fixing things here. What I've done to save me having to keep an eye on the memory usage before restarting the service manually is have NextCloud automatically restart itself every four hours:

EDIT: edited to reflect correct procedure as outlined in following post.

Logged in via ssh:
$ vi /etc/config/crontab

Added the following line to the end of the crontab file (press I to enter insert mode in vi):

Code: Select all

0 */4 * * * /etc/init.d/NextCloud.sh restart
Saved and exit (press Esc, type :wq and hit Enter). Then issued the following command:

$ crontab /etc/config/crontab && /etc/init.d/crond.sh restart

Thanks to OneCD (post below) for the corrections made to this.
Last edited by nickdanp on Tue Oct 08, 2019 3:48 pm, edited 5 times in total.

User avatar
OneCD
Ask me anything
Posts: 8057
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by OneCD » Tue Oct 08, 2019 3:06 am

nickdanp wrote:
Tue Oct 08, 2019 1:09 am
Logged in via ssh:
$ crontab -e
This method should not be used in QTS. Please follow the crontab wiki: https://wiki.qnap.com/wiki/Add_items_to_crontab
nickdanp wrote:
Tue Oct 08, 2019 1:09 am
Added the following line to the end of the crontab file (press I to enter insert mode in vi):
*/240 * * * * /etc/init.d/NextCloud.sh restart
If you want a match every four hours, use:

Code: Select all

0 */4 * * * /etc/init.d/NextCloud.sh restart

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

nickdanp
New here
Posts: 4
Joined: Sun Jul 23, 2017 4:56 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by nickdanp » Tue Oct 08, 2019 3:40 pm

Thank you for the corrections. Applying them now.

mitch569
New here
Posts: 9
Joined: Thu May 02, 2019 6:36 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by mitch569 » Wed Oct 16, 2019 1:11 pm

Thanks for the workaround, applied it a couple of days back and all seems good :)

Pawliko
New here
Posts: 9
Joined: Mon Oct 15, 2018 4:44 am

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by Pawliko » Tue Oct 29, 2019 5:50 am

Hi,
Since last update of firmware and php/apache, is it possible to switch from Qapache to native qnap setup?

yanuk
Know my way around
Posts: 115
Joined: Mon Feb 08, 2016 9:45 am

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by yanuk » Sun Nov 03, 2019 11:47 am

I have a similar question, anyone upgraded to QTS 4.4.1 while running Nextcloud? Any issues so far? I've held out upgrading qts because I'm afraid of breaking nextcloud, as postgresql will be removed after upgrading to QTS 4.4.1
Anyone have experience?
TS451
TS453

tazzi
Starting out
Posts: 15
Joined: Tue Aug 30, 2016 1:00 pm

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by tazzi » Wed Nov 06, 2019 2:43 pm

Pawliko wrote:
Tue Oct 29, 2019 5:50 am
Hi,
Since last update of firmware and php/apache, is it possible to switch from Qapache to native qnap setup?
yanuk wrote: I have a similar question, anyone upgraded to QTS 4.4.1 while running Nextcloud? Any issues so far? I've held out upgrading qts because I'm afraid of breaking nextcloud, as postgresql will be removed after upgrading to QTS 4.4.1
Anyone have experience?
I installed NextCloud on my TS451+ with latest firmware (had never used the qnapclub package so a clean install). I just used the web installer method detailed on the NextCloud website (one of the 'download for server' options). I have also installed the PHPMyAdmin package available from the app store, but cannot remember if I 'needed' to do this for the install to work or not - I possibly had to create the nextcloud database using it before the install would complete but not sure.

User avatar
dolbyman
Guru
Posts: 20404
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: [ NextCloud ] [ 17.0.0 ] OwnCloud Fork

Post by dolbyman » Wed Nov 20, 2019 12:00 pm

crypto ransomware for nextcloud

https://www.bleepingcomputer.com/news/s ... x-servers/

be on the guard and have backups

yanuk
Know my way around
Posts: 115
Joined: Mon Feb 08, 2016 9:45 am

Re: [ NextCloud ] [ 17.0.1 ] OwnCloud Fork

Post by yanuk » Wed Dec 04, 2019 4:06 pm

Just realised that NC was gogbbling up all my ram. 32gb and more if other processes quit. Didn't realise it until recently I noticed that my NAS was running considerably slower and laggy...

edit: funny.. after restarting it builds back up to 9gb ram usual in 2 mins.. ouch
You do not have the required permissions to view the files attached to this post.
TS451
TS453

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 17.0.1 ] OwnCloud Fork

Post by QNAP_Stephane » Wed Dec 04, 2019 10:35 pm

have a try the solution proposed in Qapache thread

editing /opt/NextCloud/httpd.conf

-> limit the memory usage with using another Multi-Processing Module in /opt/Qapache/etc/httpd.conf:

comment:
#LoadModule mpm_event_module libexec/mod_mpm_event.so

uncomment:
LoadModule mpm_prefork_module libexec/mod_mpm_prefork.so
Include etc/extra/httpd-mpm.conf

and restart qpkg
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

yanuk
Know my way around
Posts: 115
Joined: Mon Feb 08, 2016 9:45 am

Re: [ NextCloud ] [ 17.0.1 ] OwnCloud Fork

Post by yanuk » Fri Dec 06, 2019 6:48 pm

Thanks for the suggestion Stephane,
I got the following error after the change.

Code: Select all

(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:45080
no listening sockets available, shutting down
AH00015: Unable to open logs
TS451
TS453

Post Reply

Return to “Community Apps”