[ NextCloud ] [ 20.0.1.0] OwnCloud Fork

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
purezerg
Getting the hang of things
Posts: 54
Joined: Wed Nov 18, 2009 7:41 pm

Re: [ NextCloud ] [ 17.0.2 ] OwnCloud Fork

Post by purezerg » Wed Jan 08, 2020 9:34 pm

it worked. thank you.

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 18.0.0 ] OwnCloud Fork

Post by QNAP_Stephane » Sat Jan 18, 2020 10:36 pm

updated
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

MikeLagit
Easy as a breeze
Posts: 332
Joined: Fri Mar 22, 2013 11:40 pm

Re: [ NextCloud ] [ 18.0.0 ] OwnCloud Fork

Post by MikeLagit » Fri Feb 14, 2020 1:42 pm

I have a TS-877 NAS I would like to put this on. Can someone please explain the versions? There is:

Nextcloud that requres Qapache
or
Nextcloud that requires Apache73
or
Nextcloud that requires Apache74

Which version do i need?

And seems like there is also another apache version?

https://www.qnapclub.eu/en/qpkg/735

-ML
Model: TVS-872XT 16GB
(HDD): [RAID-5] 6 x 8TB Seagate Ironwolf

Model: TS-877-1700 16GB
(HDD): [RAID-5] 4 x 8TB Seagate Ironwolf

Model:TS-569L 3GB
(HDD): [RAID-5] 4 x 3TB WD Red

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 18.0.1 ] OwnCloud Fork

Post by QNAP_Stephane » Thu Feb 20, 2020 1:12 am

updated
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

Trigun
First post
Posts: 1
Joined: Mon Oct 19, 2015 9:36 am

Re: [ NextCloud ] [ 18.0.1 ] OwnCloud Fork

Post by Trigun » Sat Feb 22, 2020 2:34 am

Anyone having issues after the update to 18.0.1? Can't seem to open nextcloud anymore and not seeing anything in the logs. Since I have everything backed up I removed the app and reinstalled it. Noted there is no config.php created and the wizard does not start. When I checked my config file before removing I noticed it still had the version listed as 17.0.2.1 and not 18.0.1

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by QNAP_Stephane » Sat Apr 25, 2020 12:10 am

updated to 18.0.4
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by QNAP_Stephane » Sat Apr 25, 2020 12:13 am

NOTE

on some NAS there is an issue with ARGON2 algorythm hash enable by depfautl on Apache73 and Apache74

this create a white page after Wizard

here are two tips :

added to the config file on last line : /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/config/config.php

Code: Select all

  'hashing_default_password' => true,
config file look like this one after a second setup (tested with sqlite and apache74, but this trick should work for all DB and Apache73)

Code: Select all

<?php
$CONFIG = array (
  'instanceid' => 'ocg61wiq87m3',
  'passwordsalt' => 'ydniAQlWFcDG9MMAWzMlK8XkvgLZro',
  'secret' => 'O2DHiLvehj3VCsRPCak+sHUzSUXcJOPnJ9+knoHrN8qYJ5O5',
  'trusted_domains' => 
  array (
    0 => '192.168.0.59:35180',
  ),
  'datadirectory' => '/share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data',
  'dbtype' => 'sqlite3',
  'version' => '18.0.4.2',
  'overwrite.cli.url' => 'http://192.168.0.59:35180',
  'hashing_default_password' => true,
);

Second trick

other solution found by user on www.forum-nas.fr

seems that there is bug with PASSWORD_ARGON2I algorithm to generate password. Solution:

comment lines 208, 209, 210 in nextcloud/lib/private/Security/Hasher.php such that they look like:
//if (\defined('PASSWORD_ARGON2I')) {
// $default = PASSWORD_ARGON2I;
//}
This will fallback to old hash algoreithm.
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

MJaenichen
Starting out
Posts: 11
Joined: Fri Jan 30, 2015 3:36 am

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by MJaenichen » Mon May 25, 2020 12:27 am

Hi,
This is a TS653B with QTS 4.4.2.1310, QApache 2438.7216, Nextcloud 18.0.4 (paid)

I am having a number of small issues hardening my installation. Esp these I'd like to get rid of:
  • Last background job execution ran 1 hour ago. Something seems wrong. Check the background job settings
  • MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read the documentation page about this.
  • The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.
Unfortunately the links provide general information for a standard Linux-system but as QNAP goes its own way I fail to find the right locations for the files to change the settings.

I there a special "NextCloud for QNAP" readme which I missed?
Please give some more details on how to harden the system.

Thanks.
M.

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by QNAP_Stephane » Mon May 25, 2020 1:12 am

Last background job execution ran 1 hour ago. Something seems wrong. Check the background job settings
No idea
MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read the documentation page about this.
seems due to your MariaDB backend version and DB settings
The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips ↗.
think this should be applied inside /opt/Qapache/httpd.conf (and restart Qapache to applied) , it is curently not using VHOST
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

User avatar
kuznetsoff
New here
Posts: 4
Joined: Thu May 07, 2020 10:26 pm

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by kuznetsoff » Tue May 26, 2020 6:55 am

Greetings,

I'm using latest Nextcloud qpkg (18.04 Apache73)
I'm trying to configure it using MariaDb
I've created dedicated user in MariaDB and db using utf8mb4_general_ci. then i've ran NextCloud configuration
After fulfilling of db connection info i've presset finish and got
ERR_EMPTY_RESPONSE in 1 min

i see that a new tables where created in my selected db but next nextcloud web page refresh brings me back to configuration wizard.

Please advise.

PS: i'm running this on TS-453a as NetCloud (Apache73) + MariaDb + Apache73

Thanks!
TS-453a

User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by QNAP_Stephane » Thu May 28, 2020 3:51 pm

kuznetsoff wrote:
Tue May 26, 2020 6:55 am
Greetings,

I'm using latest Nextcloud qpkg (18.04 Apache73)
I'm trying to configure it using MariaDb
I've created dedicated user in MariaDB and db using utf8mb4_general_ci. then i've ran NextCloud configuration
After fulfilling of db connection info i've presset finish and got
ERR_EMPTY_RESPONSE in 1 min

i see that a new tables where created in my selected db but next nextcloud web page refresh brings me back to configuration wizard.

Please advise.

PS: i'm running this on TS-453a as NetCloud (Apache73) + MariaDb + Apache73

Thanks!
did you fixed ARGON2 issue in config file (see upper)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

User avatar
kuznetsoff
New here
Posts: 4
Joined: Thu May 07, 2020 10:26 pm

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by kuznetsoff » Sat May 30, 2020 2:10 am

Thanks!

after applying patch config completted succesfully!

Thanks you
TS-453a

vindex777
New here
Posts: 2
Joined: Thu Jun 04, 2020 2:40 pm

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by vindex777 » Thu Jun 04, 2020 2:42 pm

Hi may be someone had same issue, and know how to fix it.
During uploading files on the QNAP NAS, through browser or Nextcloud client, if there is small files all going fine, but it is take longer time to upload bigger file, I'm getting error "Connection close". Once I manage to upload one big file, through the browser, in parallel uploading another file through the client with the holding and resuming connections.
Seems like there is some time frame limit for connection to server or run the script, but i couldn't find where it is.

Already changed all settings in " .qpkg/Qapache/etc/conf/php.ini " like below, restarted the server:

max_execution_time = 36000
max_input_time = 36000
post_max_size = 10G
upload_max_filesize = 10G
memory_limit = 16G

change settings at the file " .qpkg/NextCloud/nextcloud/lib/base.php "
as below, restarted, and still nothing

//try to set the maximum execution time to 60min
if (strpos(@ini_get('disable_functions'), 'set_time_limit') === false) {
@set_time_limit(36000);
}
@ini_set('max_execution_time', '36000');
@ini_set('max_input_time', '36000');

//try to set the maximum filesize to 10G
@ini_set('upload_max_filesize', '10G');
@ini_set('post_max_size', '10G');
@ini_set('file_uploads', '50');

Very interesting to fix this issue. I have [NAS QNAP TS-453Be], using Windows 10 and Linux Mint 18 the same problem.

vindex777
New here
Posts: 2
Joined: Thu Jun 04, 2020 2:40 pm

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by vindex777 » Mon Jun 08, 2020 12:15 pm

Seems I found the issue last line in previous post the

@ini_set('file_uploads', '50'); changed from 50 to 5000
@ini_set('file_uploads', '5000'); and it is got possibility ti upload the biggest file with increased time frame.

neofun
New here
Posts: 8
Joined: Thu Jan 03, 2013 6:45 am

Re: [ NextCloud ] [ 18.0.4 ] OwnCloud Fork

Post by neofun » Sat Jun 13, 2020 9:27 pm

Hello all,
my problem (Nextcloud & QApache on TVS-x73) is found all around the QNAP forums, but I didn't find the one article with a solution yet. I wanted to install the Nextcloud App and as required installed the QApache App. Yes ist was running (so the NAS said) and since it wasn't too expensive to buy the Nextcloud App, I bought this one.
Well, after digging deeper I found out, that the QApache App didn't run as stated by the QNAP WebUI. Yes, commenting out mod_ssl "solved" the problem and yes, after that I found all the articles stating the TVS-x73 QAPache mod_ssl problem, but I need https for Nextcloud. Okay to cut a long story short:

Which is the working Nexcloud App setup for TVS-673?

It would be nice, if I don't have to run Apache & Nextcloud on a separate VM.

Greetings and thanks for your help
Neo

Post Reply

Return to “Community Apps”