[ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
User avatar
QNAP_Stephane
Experience counts
Posts: 3867
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by QNAP_Stephane » Wed Sep 09, 2020 12:55 am

it has been updated to 4.2 with python 3.7.9 embedded
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

tetardbleu
New here
Posts: 6
Joined: Mon Sep 07, 2020 7:15 am

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by tetardbleu » Wed Sep 09, 2020 1:07 am

Thank you !!!

sprogger
Starting out
Posts: 25
Joined: Mon Aug 05, 2013 7:33 pm

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by sprogger » Wed Sep 09, 2020 7:36 am

Hi Stephane
So just to be clear ... to avoid the issue I should update Python to 3.7.9 before I hit the Update Now button in Medusa?

Cheers
Sprogger

sprogger
Starting out
Posts: 25
Joined: Mon Aug 05, 2013 7:33 pm

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by sprogger » Wed Sep 09, 2020 8:11 am

Updated question..
In the QNAP club store I can see qpython 3.8.0 .. Is this the correct qpkg to install?

Cheers
Sprogger

tetardbleu
New here
Posts: 6
Joined: Mon Sep 07, 2020 7:15 am

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by tetardbleu » Wed Sep 09, 2020 9:53 am

@sprogger
You just have to make a backup of your medusa configuration, uninstall old medusa pkg and install new updated pkg from qnapclub. No need to install python qpkg. when the new version is up and running, use the restore function of medusa to retrieve your configuration.

sprogger
Starting out
Posts: 25
Joined: Mon Aug 05, 2013 7:33 pm

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by sprogger » Wed Sep 09, 2020 9:56 am

Thanks tetard .. will give that go

sprogger
Starting out
Posts: 25
Joined: Mon Aug 05, 2013 7:33 pm

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by sprogger » Wed Sep 09, 2020 10:38 am

Up and running on 4.2.. many thanks for your help ..

Have a good day

Cheers
Sprogger

tetardbleu
New here
Posts: 6
Joined: Mon Sep 07, 2020 7:15 am

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by tetardbleu » Wed Sep 09, 2020 10:58 am

well... now there is a 4.3 out, but you can use the usual medusa prompt to update as before !
Cheers !

sprogger
Starting out
Posts: 25
Joined: Mon Aug 05, 2013 7:33 pm

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by sprogger » Wed Sep 09, 2020 3:59 pm

Woops .. spoke too soon... just saw error messages on the 4.2 console

Just realised in upgrading from 2.11 to 4.2 using the backup and restore method .. the new 4.2 install has lost many of my setting (NZB search settings and NZB search providers have disappeared)

backed out to 2.11 again .. restore of settings work in this release..'

Will have to manually record settings prior to next attempts..

Ouch
Sprogger

tetardbleu
New here
Posts: 6
Joined: Mon Sep 07, 2020 7:15 am

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by tetardbleu » Wed Sep 09, 2020 6:01 pm

Sorry about that. I couldn’t say as I don’t use NZB. I noticed that some minor settings were reset on my side but not providers. Maybe Stéphane will have a suggestion for you on how to solve this. As I admit I don’t know. I didn’t suggest that you install the new qpkg over the old one directly because I was guessing it wouldn’t work, I was afraid that app center wouldn’t recognize that was the same app and that the two would enter in conflict, but if you have a working backup, maybe it is worth a try?
Good luck
Edit
oops...
spoke too soon to... I also lost providers...

User avatar
daNutz
Starting out
Posts: 35
Joined: Mon May 07, 2012 10:04 pm
Location: London, UK

Re: [ Medusa ] [ 0.4.2 ] Automatic Video Library Manager for TV Shows

Post by daNutz » Wed Oct 21, 2020 11:42 pm

Anyone know how to get Medusa to use Python 3?

Code: Select all

Medusa Info:	Branch: master
Commit: b352bb6924afcdfafce176a540d53ce405ca1312
Version: 0.4.3
Database: 45.16
 Python Version:	2.7.13 (default, Apr 11 2017, 16:05:39) [GCC 4.8.4]
 SSL Version:	OpenSSL 1.0.2k 26 Jan 2017
 OS:	Linux-4.2.8-x86_64-with-glibc2.2.5
 Locale:	en_US.UTF-8
 	 
 	 
 User:	admin
 Program Folder:	/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa
 Config File:	/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/config.ini
 Database File:	/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/main.db
 Cache Folder:	/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/cache
 Log Folder:	/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/Logs
 Arguments:	
-p 22121 --daemon
If i following the guide here i get the below errors

Code: Select all

Orig: export PYTHON=$QPKG_ROOT/bin/python
Updated: export PYTHON=/opt/bin/python

Python (v3.8.5) = /opt/bin/python

Error

Code: Select all

Traceback (most recent call last):
  File "SickBeard.py", line 6, in <module>
    from medusa.__main__ import main
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/medusa/__init__.py", line 24, in <module>
    initialize()
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/medusa/init/__init__.py", line 34, in initialize
    _urllib3_disable_warnings()
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/medusa/init/__init__.py", line 150, in _urllib3_disable_warnings
    import requests
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/requests/__init__.py", line 43, in <module>
    import urllib3
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/urllib3/__init__.py", line 8, in <module>
    from .connectionpool import (
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/urllib3/connectionpool.py", line 11, in <module>
    from .exceptions import (
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/urllib3/exceptions.py", line 2, in <module>
    from .packages.six.moves.http_client import (
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/urllib3/packages/six.py", line 203, in load_module
    mod = mod._resolve()
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/urllib3/packages/six.py", line 115, in _resolve
    return _import_module(self.mod)
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/urllib3/packages/six.py", line 82, in _import_module
    __import__(name)
  File "/share/CACHEDEV1_DATA/.qpkg/Medusa/Medusa/ext/http/__init__.py", line 7, in <module>
    raise ImportError('This package should not be accessible on Python 3. '
ImportError: This package should not be accessible on Python 3. Either you are trying to run from the python-future src folder or your installation of python-future is corrupted.
QNAP TS-1079Pro - 30TB - RAID 6 - FW: 4.3.6.1446

Plex Server
SABnzbd+ v3.1.0
Medusa
Watcher3
NZBHyrda2
Git v2.27.0
Entware 3x
Python v3.8.5

Online Support Form
File Downloads
HDD Compatibility
Become a QNAP Fan

Post Reply

Return to “Community Apps”