Client site encryption crashes connection

Post Reply
mderemer
Starting out
Posts: 12
Joined: Sun Aug 05, 2012 7:53 am

Client site encryption crashes connection

Post by mderemer » Sun Mar 29, 2015 8:11 am

I'm very excited to see QNAP support Google Cloud Nearline so directly with a qpkg. These 3 features are key for me:
Manual and scheduled backup/restore with flexible options
Full and incremental backup
SSL transfer encryption and client-side AES-256 encryption


I am having a problem though. I ran through the Nearline and Cloud station setup with no problems, but when I ran my first job it only makes it through 5~15 files then cancels itself with the log entry that the job failed due to an "unknown error". Through some trail and error I found that if I turned off the client side encryption everything works fine. I'd really prefer that my data be client side encrypted since its no longer under my physical control.

Has anyone seen and resolved this problem?

I SSH'ed in and confirmed that I did have the latest version of OpenSSL installed.
===
TS-221
TS-219P II

mderemer
Starting out
Posts: 12
Joined: Sun Aug 05, 2012 7:53 am

Re: Client site encryption crashes connection

Post by mderemer » Sun Mar 29, 2015 8:22 am

UPDATE: I installed the latest QNAP firmware and it appears to resolve the problem.
In the course of this I also set every parameter to 255 (ie. maximum number of retries), but I'm pretty sure it was the firmware that did it.

UPDATE2:
Well better, but still problematic... I made it through 290 files then failed. Looks like this first backup will be a struggle.

UPDATE3:
Copied 1,000+ files with this go, but still not complete... yup just keep restarting...

UPDATE4:
On average its doing 3 GB before stopping...
===
TS-221
TS-219P II

paulchu

Re: Client site encryption crashes connection

Post by paulchu » Mon Mar 30, 2015 12:05 am

Hi, this is abnormal. Please contact QNAP helpdesk and send them the debug log of your App. You can download the debug log by pressing the [i] button on the top-right corner of your CloudBackup App Window. Thank you.

mderemer
Starting out
Posts: 12
Joined: Sun Aug 05, 2012 7:53 am

Re: Client site encryption crashes connection

Post by mderemer » Wed Apr 15, 2015 11:06 am

UPDATE 5:

After sending more detailed logs into QNAP I got this response.

"According to the logs, there was a file that could not be backed up to Google Cloud Storage because the file name contains non-UTF-8 characters. Which broke the backup job.
...
We will release new app version that will skip these kind files to ensure that the backup continuing. The job will also log these special files, such that the user can find the files and manually rename the files to complete the backup. "


So Mötley Crüe was to blame!

Although not all inclusive I ran

Code: Select all

find | grep [äöüÄÖÜß]

to find the obvious offenders... and since the number was small I renamed them by hand.

Re-running now...
===
TS-221
TS-219P II

Post Reply

Return to “Google Cloud Storage”