Can't access shares of a degraded RAID 5

Discussion about using NAS on Linux and Unix OS.
Post Reply
blub
Starting out
Posts: 13
Joined: Mon May 16, 2011 2:38 am

Can't access shares of a degraded RAID 5

Post by blub » Wed May 10, 2017 5:10 am

Hi

I have a difficult issue:

I have a TS451 with 4x5TB Seagate IronWulf as a RAID 5. Two of the drives are showing status "abnormal" (3 & 4). After checking the disks no errors were found so I did a "recovery of the RAID" and after a reboot it finished the rebuild.
The RAID 5 Volume is now shown as "ready", however with FIleStation I cannot create any files/folders (so its read only) - but I can see my data and downloads via FileStation suggest that the data is still valid.

However I juts cannot connect to the NAS via CIFS/SMB. I used to just mount it in Ubuntu via fstab just fine with this entry:

Code: Select all

//192.168.100.42/video  /media/NASMount  cifs  guest,uid=1000,iocharset=utf8  0  0


But that now gives me the error:

Code: Select all

Unable to find suitable address.
- Access via Windows is also not working.

However nothing has changed except the fact that RAID failed - so the IP address I use is valid.

I even did a NAS reset to clear all settings and the issue still persist.

Is that a normal behavior of the NAS? - I do have a backup, so that's not the issues. However I have no physical access to the NAS and I can only sent a person there once to replace 1 drive (not 2 due to time contraints).
So it's either I can access the data, then I would replace 1 drive and the other at a later point in time or mail the whole NAS back to me.

thx for any help

Post Reply

Return to “Linux & Unix (NFS)”