[FIX] Fix slow NFS performance between QNAP NAS & All TviX

Discussion about using NAS on Linux and Unix OS.
User avatar
AndyChuo
Experience counts
Posts: 2396
Joined: Thu Sep 13, 2007 11:56 am
Location: Taipei, Taiwan

[FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by AndyChuo » Thu Feb 14, 2008 5:34 pm

Hi Guys,

Sorry for the long wait but I think we locked down the problem and solved it.
NFS on QNAP NAS now works perfectly with all the TviX series players

Please update the corresponding firmware image below:
Guys, we've fixed this problem finally.

Please update the corresponding firmwares below:
TS-109 / TS-109-Pro
TS-209 / TS-209-Pro

Thanks guys

Andy
=============================================================>>>
TS-659-Pro [RAID6] rtorrent+SABnzbdplus+SickBeard+Couchpotato [Best PVR] Plex+PMS [Ultimate Streamer]
Apple iPad [Best Tablet] HTC One M8 [Mobile Phone] Samsung UA46ES6100 [My Screen] KRK Rokit 6 [Audio Speakers]
Chrome Cast [Screen Casting] Philips Hue [Personal Lighing]
Buffalo WZR-1750DHP [My Wifi Hub] D-Link DGS-1005D [Gbit Network]
=============================================================>>>

hstream
First post
Posts: 1
Joined: Fri Feb 15, 2008 11:42 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by hstream » Fri Feb 15, 2008 11:47 pm

Hi Andy.

Do you have any numbers on speed with this fix? I'm looking into buying a QNAP for TVIX 4100, but the speed has got to be considerably better than the 1.9 MByte/s I get with FTP until I buy one.

Thanks.

Hstream

doggiehowser
Getting the hang of things
Posts: 51
Joined: Sun Nov 04, 2007 8:05 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by doggiehowser » Tue Feb 19, 2008 10:38 am

hstream wrote:Hi Andy.

Do you have any numbers on speed with this fix? I'm looking into buying a QNAP for TVIX 4100, but the speed has got to be considerably better than the 1.9 MByte/s I get with FTP until I buy one.

Thanks.

Hstream


It works great. I can stream 720p MKV over Ethernet as well as over a 50+Mbps Ethernet over Power. Haven't tried wireless but doubt it is a good choice.

tmpzero
New here
Posts: 2
Joined: Fri Sep 28, 2007 5:43 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by tmpzero » Wed Feb 20, 2008 6:20 pm

Sorry for asking this but does this mean I can run NFS on the regular TS-209 now?

I need NFS support for my TViX but I was under the impression that NFS only is available on the Pro models?

I would love to see NFS support on all modells and leave ADS for the business users needing AD integration, but I'm a "power homeuser" running TViX and Linux at home and NFS are some of a key-feature for me.

regards
Fred

Subw00er
Getting the hang of things
Posts: 87
Joined: Mon Sep 24, 2007 10:08 am

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by Subw00er » Mon Feb 25, 2008 1:34 pm

update did not fix my problem which may be related - http://forum.qnap.com/viewtopic.php?f=13&t=2634

I've spent thousands on your hardware, Andy. PLEASE address this problem.

doorhof
New here
Posts: 9
Joined: Sat Mar 08, 2008 2:06 am

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by doorhof » Sat Mar 08, 2008 2:10 am

Hi,
Same kind of problem here.
Could you please make the link of the 2.0.0 firmware work ?

Or please mail me the firmware on info@doorhof.nl

We are now having one Qnap in the TD with this problem and I want to deliver it back to the customer.

dgefter
New here
Posts: 5
Joined: Mon Mar 03, 2008 1:56 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by dgefter » Wed Mar 12, 2008 9:52 am

I'm having same really bad performance with NFS on TS-409 Pro (firmware vers. 2.0.0-0122T) using Tvix 4100sh. There is a long delay when playing a file and the playback is very choppy. Smb connection is better. I was wondering if the fix for NFS is included into the latest TS-409 firmware?

Thanks,

Denis

User avatar
QNAPIvan
Experience counts
Posts: 1021
Joined: Mon Jul 02, 2007 4:03 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by QNAPIvan » Thu Mar 13, 2008 6:33 pm

Dear Denis
Can you help to upgrade with the lastest firmware, and let us know if it works for you?
http://www.qnap.com/download_detail.asp ... e=Firmware

Cheers,


dgefter wrote:I'm having same really bad performance with NFS on TS-409 Pro (firmware vers. 2.0.0-0122T) using Tvix 4100sh. There is a long delay when playing a file and the playback is very choppy. Smb connection is better. I was wondering if the fix for NFS is included into the latest TS-409 firmware?

Thanks,

Denis
________________________________________
Product Marketing Director
USA Online Support: http://www.qnap.com/i/useng/before_buy/con_show.php?op=showone&cid=2
Support email: q_supportus@qnap.com
USA Technical Support: +1 909 595 2782

dgefter
New here
Posts: 5
Joined: Mon Mar 03, 2008 1:56 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by dgefter » Thu Mar 20, 2008 9:45 am

Hello,

I've upgraded to 2.0.1 Build 080226. When I connect both Tvix and QNap to router which is 10/100 - everthing works. If I connect either Tvix or Qnap to my switch (D-Link DSG-2208), the performance is bad (playback is very chuppy). Jumbo frames are disabled on QNap.
Any help?

Thanks,

Denis

User avatar
fribse
Experience counts
Posts: 2079
Joined: Mon Feb 11, 2008 2:50 am
Location: Greve, Denmark
Contact:

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by fribse » Thu Mar 20, 2008 4:45 pm

dgefter wrote:Hello,

I've upgraded to 2.0.1 Build 080226. When I connect both Tvix and QNap to router which is 10/100 - everthing works. If I connect either Tvix or Qnap to my switch (D-Link DSG-2208), the performance is bad (playback is very chuppy). Jumbo frames are disabled on QNap.
Any help?
Thanks,
Denis


Googling a bit, shows some strange problems with speed and the DGS-2208. I can see there's no management interface in it, so no way of forcing the link speed.
My suggestion is that the equipment is constantly renegotiating speed, this will impair the transfer to an extreme degree.
Some gigabit's just doesn't like each other, I've seen this with HP, IBM, Cisco, and then the speed has to be locked manually.

You are using Cat5e cables or better?

Could you try a test setup with short new Cat5e cables (or Cat6) that haven't been twisted or bent in any way, and see if that helps?
Best regards
Fribse

NO, RAID is NOT backup - Use RAID-Certified 24x7 drives for raid
HOWTO's:
Make automatic backup of ALL MySQL databases http://forum.qnap.com/viewtopic.php?f=32&t=15628

NAS-659 Pro II (3 GB Ram), Raid1, Survailance station, local backup destination + NAS-853A (16 GB Ram), Virtualization Station, Plex, iDrive
Network: Fritz!Box 7560 + 24p SG200 + 2x8p SG200 + 8p POE EdgeCore + 300/300 mbit Internet

User avatar
KL643
Experience counts
Posts: 2027
Joined: Sun Sep 23, 2007 9:21 pm
Location: @40000ft

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by KL643 » Thu Mar 20, 2008 5:51 pm

dgefter wrote:Hello,
If I connect either Tvix or Qnap to my switch (D-Link DSG-2208), the performance is bad (playback is very chuppy). Jumbo frames are disabled on QNap.
Any help?
Thanks,
Denis


I'm having the same issue with my Qnap 109-Pro and the Popcornhour A-100 and a Sitecom Gigaswitch. Playing the files over SMB is even better than over NFS. It could be the switch causing the problem. There are some people who had the same problem and replaced their switch for a netgear switch and solved the issue.
The solution to the most difficult "problem" is usually very simple.

Qnap support

Before asking questions

dgefter
New here
Posts: 5
Joined: Mon Mar 03, 2008 1:56 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by dgefter » Fri Mar 21, 2008 4:35 am

I tried connecting with new Cat5e cables - it didn't change anything. Interestingly enough, if I enable NFS on my laptop (which is also connected to the DSG-2208 switch), everything works fine.

KL643, which model of netgear switch do you think will work?

User avatar
KL643
Experience counts
Posts: 2027
Joined: Sun Sep 23, 2007 9:21 pm
Location: @40000ft

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by KL643 » Fri Mar 21, 2008 2:25 pm

I know some people on the Popcorn forum use a GS106 or GS105 and have no problem.

Edit: For me no solution. If i don't use the gigaswitch some files still stutter at some point. So a new switch won't make any difference for me.
The solution to the most difficult "problem" is usually very simple.

Qnap support

Before asking questions

leven
Starting out
Posts: 18
Joined: Wed Mar 26, 2008 4:40 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by leven » Wed Mar 26, 2008 4:53 pm

Is this Fix avaliable for the 409-Pro?

I have the latest 409-Pro firmware and the NFS performance is horrible against the Tvix 6500A, about 5min for opening a 2megabyte mp3, i can see the files though. ;)

Samba work a lot better a.t.m but i would perfer to use NFS because the Tvix is a lot faster w NFS for HD content.

Using Gigabit trough a Dlink-4300 (wifi/gigabit router/switch) w Cat6 cable.

BR
/Leven

User avatar
QNAPIvan
Experience counts
Posts: 1021
Joined: Mon Jul 02, 2007 4:03 pm

Re: [FIX] Fix slow NFS performance between QNAP NAS & All TviX

Post by QNAPIvan » Sun Mar 30, 2008 11:31 pm

Dear Leven
Can you let me know yur firmware version?
And is it set up in the 10/100 & Gigabit mixed environment?

Cheers,
________________________________________
Product Marketing Director
USA Online Support: http://www.qnap.com/i/useng/before_buy/con_show.php?op=showone&cid=2
Support email: q_supportus@qnap.com
USA Technical Support: +1 909 595 2782

Post Reply

Return to “Linux & Unix (NFS)”