QNAP TS-251+ random POST success and bootup

Don't miss a thing. Post your questions and discussion about other uncategorized NAS features here.
Post Reply
New here
Posts: 2
Joined: Thu Aug 13, 2020 12:04 pm

QNAP TS-251+ random POST success and bootup

Post by coolquasar » Thu Aug 13, 2020 1:20 pm

Hello all,

I have been using QNAP TS-251+ for the past 4 years, with no problem, until now.

Long story short: When turned on, it is a hit and miss that POST will be success and system boots up. Suggestions required

A couple of weeks ago, I turned ON the QNAP, and when I checked after half hour, I couldn't access it, and router did not have IP assigned to it. The system had Status light, LAN and HDD1 lights ON, with almost no flicking. I didn't suspect too much, and rebooted by turning off and on. It came back up working and accessible.

Couple of days ago, same thing happened, but this time, it wouldn't boot up. Status light, LAN and HDD1 lights are ON, but no POST completion beep. I removed the HDD and turned it on, still it wouldn't POST. I had a Crucial 4GB RAM in the system. I immediately suspected a gone RAM module, so swapped it with factory RAM (2 GB Transcend). Once powered ON, POST still failed. I thought, RAM didn't seat properly, so reseated it again. This time, POST was successful, and I could see the DOM's blue blight blinking. (At this point the system was open with no HDD). I swapped the RAM again, this time seated the Crucial 4GB (Removed Transcend). It did the POST successful this time. I was almost sure the problem was fixed. Just in case, I swapped it back with Transcend 2GB (Factory RAM), inserted HDD. It wouldn't boot up, with no beep after the POST.

I suspected a gone CMOS battery, and swapped with a new one and powered it on. Still the same, no POST completion beep. At this time, I was turning ON/OFF multiple times with no HDD, with factory RAM an with new CMOS battery. It never turned ON (no POST completion). I almost concluded a H/W problem, that it will never turn ON and reported to QNAP. They immediately suggested to swap out the board. I started working with the contact provided by QNAP service to understand the cost and logistics to get the board replaced.

At this point, I was also worried if my data in HDD was intact. I didn't have an external casing to immediately verify it.

Meanwhile, I wanted to try some luck, and continued to turn ON/OFF few times, with and without HDD inside. To my surprise, POST completed with a beep, and DOM blue light started blinking. I was able to find it in Qfinder and opened the web portal of QNAP. It had options to reset to factory settings or Initialize. Since reset to factory settings didn't erase data, I took that option, and successfully booted into QTS. I had to create user again (running QTS 4.4.1117), and mount the shares. I logged in through ssh and confirmed data was intact. I connected an external HDD and backed up almost 1 TB of critical data from the QNAP HDD. It took almost 4 hrs to complete the process. Meanwhile, I was monitoring system performance, and it was normal as usual. All status indicator said, it was Good, no problem with the disk. Once I completed back up process, I performed a firmware update, and rebooted.

Now, it wouldn't boot up, taking back to the previous situation, no POST beep. I turned ON/OFF few times, and POST beep come through once and successfully booted into QTS. This time, I ran full disk check. Disk check completed successfuly with no failure. The system was ON for full 12 hrs with access to data, until there was a power outage. QNAP is powered through an UPS. So, it was ON, until UPS battery ran out.

At this point, it is not clear to me, what could be causing the problem
1. Faulty RAM ? - May be not, Both factory RAM and Crucial 4GB had successful POST beep
2. Dead CMOST battery ? - It is taken care, I swapped with 2 new CMOS batteries
3. Dead PSU ? - May be, but when the system turned ON and booted up, it stayed on for 12 hrs
4. Is PSU giving inconsistent Voltage/Current output ? - May be, not sure. I do not have the tools to check
5. Is any Power IC a goner ? Not sure, I do not have tools to test
6. Is BIOS corrupted ? - No, as it powered on fully well and working. with dmidecode, I have taken the full dump of the system details into a file
7. Is DOM corrupted or gone ? No - system booted up fully, and I was also able to successfully upgrade with the latest firmware

Please provide me suggestions before I have to swap out the board. The QNAP service center confirmed, that they wouldn't replace any chips if they are gone. They can only replace the entire board or nothing.

Starting out
Posts: 12
Joined: Sat Jan 26, 2008 6:58 am

Re: QNAP TS-251+ random POST success and bootup

Post by BoneMatrix » Mon Aug 17, 2020 4:55 am

Possibly failing PSU...connect a VDU and Keyboard to the QNAP and on reboot, access the BIOS then verify the supplied voltages...
Or, check the RAM is seated properly?
TS-259 Pro+ 3.7.3 (2x1TBytes in RAID 1)
TS-209 Pro 3.3.2 (1x500GBytes)

5xWinXP Pro SP2 (Simple File Sharing disabled)
2xUbuntu 10.04 LTS Linux
MacBook OS 10.x
3xBlackberry PlayBook OS 2.1
Philips SLM5500
Philips RC9800i

Intermittent SAMBA disconnects traced to router firmerware (DLINK DI-624) - upgraded to v2.75 fixed the issue.

Getting the hang of things
Posts: 75
Joined: Thu Mar 20, 2008 11:54 pm

Re: QNAP TS-251+ random POST success and bootup

Post by buggy82 » Sun Jan 10, 2021 4:31 am

Sorry, just read your question in my BIOS revival thread.

If it hangs during POST, please note the POST Code which is displayed in the bottom right. My device sometimes hangs on POST with code B4, which is some kind of USB related post and my be dependent on which devices you have attached to the USB ports and if they are already ready to respond when the NAS BIOS tries to contact them.

Especially external USB hard drives that start up with the NAS may not be ready to answer that quickly.

Kind Regards,
TS 409 Pro - decommissioned
TS 559 Pro+ - degraded to an iSCSI target, disabled all services
TS 651 + UX 800P 3xRAID5 (as Storage Pool 1), actually RAID50 + 1 Single Drive (test VMs/temp data, QTS apps)

Post Reply

Return to “Miscellaneous”