App Updates/Installs stuck on Waiting

Don't miss a thing. Post your questions and discussion about other uncategorized NAS features here.
Post Reply
nuggetz
New here
Posts: 2
Joined: Wed Mar 12, 2014 10:26 am

App Updates/Installs stuck on Waiting

Post by nuggetz » Sat Sep 05, 2020 4:37 am

I recently updated to firmware 4.3.4.1190 on a TS-869L and after the restart a lot of my existing apps were grayed out (Python2, Entware-ng, Download Station, myQNAPcloud, etc). For the remaining apps many wouldnt start as they rely on Entware. I noticed Entware had a new version available in the store so I attempted to download, along with updating the Download Station and other QNAP essentials but all remained stuck in an attempt to download the qpkg. The status on hovering the mouse only shows waiting. I left it like this for hours with zero progress. Has this happened to anyone with the 4.3.4.* updates? Any guidance on troubleshooting is appreciated. --Ryan

Edit: I should clarify also that I am able to download packages using wget from the CLI.

nuggetz
New here
Posts: 2
Joined: Wed Mar 12, 2014 10:26 am

Re: App Updates/Installs stuck on Waiting

Post by nuggetz » Sun Sep 06, 2020 1:06 pm

This all seems to be due to QSnatch Malware. I was able to manually install the Malware by SSH'ing into the box, downloading the MalwareRemover qpkg and installing the package by running the following:

Code: Select all

cd /share/CACHEDEV1_DATA/.qpkg

Code: Select all

wget https://download.qnap.com/QPKG/MalwareRemover-3.5.5.1.20200313_205516-x86_64.zip

Code: Select all

unzip MalwareRemover-3.5.5.1.20200313_205516-x86_64.zip

Code: Select all

install -i MalwareRemover/ MalwareRemover-3.5.5.1.20200313_205516-x86_64.qpkg

Code: Select all

cd /share/CACHEDEV1_DATA/.qpkg/MalwareRemover/

Code: Select all

./MalwareRemover-3.5.5.1.20200313_205516-x86_64.qpkg
After the package was installed I was able to open the AppCenter and open MalwareRemover. The scans returned the below logs

Code: Select all

Type	Date	Time	Users	Source IP	Computer name	Content	
Warning	2020/09/06	12:02:59 AM	System	127.0.0.1	localhost	[Malware Remover] Removed the detected malware: MR1902, MR1905 (QSnatch malware).	
Warning	2020/09/06	12:02:59 AM	System	127.0.0.1	localhost	[Malware Remover] Malware was detected and removed. You must restart the NAS.	
Warning	2020/09/06	12:02:58 AM	System	127.0.0.1	localhost	[Malware Remover] Detected high-risk malware. To maintain system security, change all user account passwords immediately.	
Warning	2020/09/06	12:02:18 AM	System	127.0.0.1	localhost	[Malware Remover] Removed high-risk malware. Update passwords for email account and QNAP ID.	
Warning	2020/09/06	12:02:11 AM	System	127.0.0.1	localhost	[Malware Remover] Removed high-risk malware. Restart NAS and update all apps in 'App Center' > 'My Apps' > 'Install Updates'.	
Warning	2020/09/06	12:02:10 AM	System	127.0.0.1	localhost	[Malware Remover] Removed high-risk malware. Update passwords for email account and QNAP ID.	
I found a lot of references to the cleanme.sh script but that seems to be old and out of date. This was the only thing that has worked so far.

Post Reply

Return to “Miscellaneous”