SSL

Don't miss a thing. Post your questions and discussion about other uncategorized NAS features here.
Post Reply
Orestone
Starting out
Posts: 16
Joined: Sun Jan 07, 2018 6:12 pm

SSL

Post by Orestone » Sun Sep 13, 2020 1:09 pm

Hi all
I have some problems with SSL. Finally managed to install Lets Encrypt. It works, but:
It does NOT work with Control Panel or Owncloud.
The only way to access a web site is: https or http orestone.ddns.net/demo/public_html
I do not want "public_html" to show.
It also does not accept www as a prefix
I added some screenshots as an attachment.

Grateful for some tips
/Jan
You do not have the required permissions to view the files attached to this post.

User avatar
oyvindo
Experience counts
Posts: 1146
Joined: Tue May 19, 2009 2:08 am
Location: Norway, Oslo

Re: SSL

Post by oyvindo » Mon Sep 14, 2020 2:32 am

If you want to connect to various web services in your LAN, from the internet, consider using a reverse proxy with Let's Encrypt certificates. Check out this guide: viewtopic.php?f=32&t=139548
ImageImageImageImage

Orestone
Starting out
Posts: 16
Joined: Sun Jan 07, 2018 6:12 pm

Re: SSL

Post by Orestone » Mon Sep 14, 2020 9:13 am

Thanks, I will try that
/Jan

Orestone
Starting out
Posts: 16
Joined: Sun Jan 07, 2018 6:12 pm

Re: SSL

Post by Orestone » Mon Sep 14, 2020 10:20 am

OK, checked this out. I have a NAS TS251+
System Service check does not show any Nginx. Guess I need to install it.
Would that be any problem with this NAS? I never done this before, is it safe for me to try?
Have some experience of installing Apache programs.

/Jan

User avatar
oyvindo
Experience counts
Posts: 1146
Joined: Tue May 19, 2009 2:08 am
Location: Norway, Oslo

Re: SSL

Post by oyvindo » Mon Sep 14, 2020 1:44 pm

My advise would then be to use Docker - if you can. Check out this guide: viewtopic.php?f=354&t=155970
ImageImageImageImage

Post Reply

Return to “Miscellaneous”