cannot contact NAS after rebuilding RAID

Don't miss a thing. Post your questions and discussion about other uncategorized NAS features here.
Post Reply
jwhiter
Starting out
Posts: 10
Joined: Sun Oct 06, 2019 11:31 am

cannot contact NAS after rebuilding RAID

Post by jwhiter » Mon Sep 14, 2020 11:30 am

I recently replaced a HDD in my TS431p. I did not hot swap the disks. I replaced the bad drive with one of the same capacity and model with the NAS turned off. I restarted the NAS. The status light and all four drive lights came on. The drive lights were flickering but the status light showed green. However I could not log into the NAS to check if the rebuild was happening or on the progress of the rebuild. I knew that if the RAID was rebuilding the status light should be blinking red/green so after about three hours I powered off the NAS and removed the new disk leaving the power on. The status light came on red. I replaced the disk and the status light began flashing red/green and all four disk lights were flickering. I assumed that the RAID was rebuilding but I still could not contact the NAS. After about 16 hours the status light showed solid green. There was still some flickering in the disk lights so I let things go. Now, the disk lights have been solid green for about 5 hours but I still can't contact the NAS. I don't know where to go from here. I can only think that I could power off the NAS, power on again and see what happens. Is this wise? Maybe I should just wait it out? Any advice?

User avatar
dolbyman
Guru
Posts: 20111
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: cannot contact NAS after rebuilding RAID

Post by dolbyman » Mon Sep 14, 2020 9:44 pm

can you reach the nas via ssh?

why did you not hotswap the drive ?

hope you have backups

jwhiter
Starting out
Posts: 10
Joined: Sun Oct 06, 2019 11:31 am

Re: cannot contact NAS after rebuilding RAID

Post by jwhiter » Tue Sep 15, 2020 5:35 am

Can not ssh or ping. Yes I have backup. As for hot swap, I followed Qnap advice on the web only to find contradictory advice after the event. The NAS is still in the same state as when I posted the topic. I need advice.

User avatar
dolbyman
Guru
Posts: 20111
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: cannot contact NAS after rebuilding RAID

Post by dolbyman » Tue Sep 15, 2020 5:41 am

Have you tried a reboot then ?

you can also open a ticket with qnap for live assistance

jwhiter
Starting out
Posts: 10
Joined: Sun Oct 06, 2019 11:31 am

Re: cannot contact NAS after rebuilding RAID

Post by jwhiter » Tue Sep 15, 2020 6:50 am

Rebooted. All fine. Data seems to be intact and everything working OK. Thanks.

Post Reply

Return to “Miscellaneous”