HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Discussion about hard drive spin down (standby) feature of NAS.
Post Reply
loioiian
First post
Posts: 1
Joined: Thu Jan 07, 2016 12:12 am

HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by loioiian » Thu Jan 07, 2016 12:19 am

I found that the HDD Spin Down was not working in my QNAP NAS, so I tried to locate the problem by running the blkdevMonitor.sh script through ssh.
However, no log is shown and surprisingly my HDD are able to spin down after I have run blkdevMonitor.sh once.

And the problem appears again next time I have shut down and turned on the NAS.

I am wondering what blkdevMonitor.sh have done to help my HDD spin down...

dolan.m
Starting out
Posts: 26
Joined: Fri Apr 17, 2009 9:49 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by dolan.m » Sat May 14, 2016 4:44 am

I observe exactly the same behaviour. After the system boot (pretty rare occasion in my case) my TS-251+ never spins down - until I first run "hdparm -Y" (manually or inside the blkdevMonitor.sh script). Seems like the "hdparm -Y" needs to be nudged manually before it starts to work automatically inside the built -in standby command. Anybody can provide some insight?

Qnappy219p
Starting out
Posts: 14
Joined: Sat Aug 15, 2009 2:44 am

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by Qnappy219p » Fri May 20, 2016 5:44 pm

With my TS-219P, I faced the exact same problem after installing firmware version: 4.2.1 build 20160419.

Via putty I ran the "hdparm -Y" as dolan.m suggested. It did not seem to work, so just in case I re-applied the sleep settings from the NAS control panel. Now my disks do spin down :)

Thank you @dolan.m for this tip!

Seems indeed QNAP has introduced once more the disk spin down issue that was present in previous firmware as well...

baconbrain
Starting out
Posts: 18
Joined: Wed May 11, 2016 8:50 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by baconbrain » Sat May 21, 2016 5:33 am

After the suggestion from Qnappy219p (Thx!), I also gave this a try and to my surprise my HD's now go into standby.

I still am somewhat unclear as to the syntax of the hdparm command. My understanding of the option "-Y" refers to forcing the hard disk into sleep mode and "-y" forces it into standby.

As Dolan.m mentioned, perhaps someone can shed some additional light on the topic?

ROLLINS
Getting the hang of things
Posts: 86
Joined: Tue Oct 14, 2014 10:42 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by ROLLINS » Sun May 22, 2016 7:12 am

Since i set up my 471 tuesday i've notice the same issue. I'm new to all this
what is blkdevmonitor.sh how do i run it ?

baconbrain
Starting out
Posts: 18
Joined: Wed May 11, 2016 8:50 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by baconbrain » Sun May 22, 2016 7:29 am


User avatar
oyvindo
Experience counts
Posts: 1146
Joined: Tue May 19, 2009 2:08 am
Location: Norway, Oslo

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by oyvindo » Sun May 22, 2016 6:43 pm

Question: I tried "sudo hdparm -Y" from root and all I got was "command not found" !?!
ImageImageImageImage

baconbrain
Starting out
Posts: 18
Joined: Wed May 11, 2016 8:50 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by baconbrain » Mon May 23, 2016 4:55 am

Some good explanations for the proper hdparm syntax can be found here http://www.linux-magazine.com/Online/Features/Tune-Your-Hard-Disk-with-hdparm

I only ran it once for each drive using the "-y" option. After that the drives would spin down properly until the next server (NAS) restart.

It is now sufficient for me to run the blkdevMonitor one time (limiting it to just one pass using the option 1 at the end) after a restart and the drives start spinning down again without running hdparm.

I can't explain why it works, but it does for my 471.

Benna80
Know my way around
Posts: 240
Joined: Tue May 19, 2015 4:43 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by Benna80 » Mon May 30, 2016 5:30 pm

baconbrain, which firmware version have you intalled?

User avatar
monellrt
Know my way around
Posts: 167
Joined: Tue Dec 09, 2014 2:42 am

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by monellrt » Mon May 30, 2016 8:59 pm

I have found that when I install the application "Notes Station" the drives fail to spin down. Once I remove the application, everything works well once again. QNAP is aware of this and plans to update the application. This has been a full year now that this has been happening.

baconbrain
Starting out
Posts: 18
Joined: Wed May 11, 2016 8:50 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by baconbrain » Tue May 31, 2016 1:13 am

Benna80 wrote:baconbrain, which firmware version have you intalled?


4.2.1 Build 20160419

ROLLINS
Getting the hang of things
Posts: 86
Joined: Tue Oct 14, 2014 10:42 pm

Re: HDD Spin Down not working UNTIL I have run blkdevMonitor.sh once

Post by ROLLINS » Tue Jun 07, 2016 9:21 pm

My 471 will go into standby but something keeps bringing it out, they trouble shooting it but nothing yet
At least the drives not spinning

Post Reply

Return to “HDD Spin Down (HDD Standby)”