Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Discussion about hard drive spin down (standby) feature of NAS.
Post Reply
manny2003
Getting the hang of things
Posts: 74
Joined: Sun Feb 15, 2015 8:57 am

Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by manny2003 » Thu Nov 03, 2016 7:45 pm

Since release 20161021 hard disks do not spin down anymore. This release does not fix this bug. Reverting back to 20160901 fix the problem.
Qnap NAS: HS-251 OS Ver. 4.2.2 20160901 | HD: 2x WD40EFRX | RAID: 1 | Used OS: Windows 10 x64
Qnap NAS: TS-251-4GB OS Ver. 4.2.2 20160901 | HD: 1x WD40EFRX | RAID: 0 | Used OS: Windows 10 x64

User avatar
Gusto
Getting the hang of things
Posts: 72
Joined: Sat Jun 30, 2012 5:14 pm
Location: Haarlem, The Netherlands

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Gusto » Thu Nov 03, 2016 8:09 pm

Why must hard disks spin down?
TS-469 Pro - 3GB RAM (KVR1333D3S8S9/2G) -QTS 4.3.4.1129 Build 20191107 - 4x Hitachi HUA723020ALA640 MK7O - RAID5 - with APC Back-UPS ES 550G

manny2003
Getting the hang of things
Posts: 74
Joined: Sun Feb 15, 2015 8:57 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by manny2003 » Thu Nov 03, 2016 8:25 pm

Because this is a feature of QTS that you can configure in the Control Panel -> Hardware section. Default is 30 minutes. The disks will spin down after an idle timeout.
Please read here if you need more info about this issue:
viewtopic.php?f=55&t=126958&p=576183#p576183
Qnap NAS: HS-251 OS Ver. 4.2.2 20160901 | HD: 2x WD40EFRX | RAID: 1 | Used OS: Windows 10 x64
Qnap NAS: TS-251-4GB OS Ver. 4.2.2 20160901 | HD: 1x WD40EFRX | RAID: 0 | Used OS: Windows 10 x64

User avatar
Gusto
Getting the hang of things
Posts: 72
Joined: Sat Jun 30, 2012 5:14 pm
Location: Haarlem, The Netherlands

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Gusto » Thu Nov 03, 2016 8:50 pm

Let them run at full speed for 24/7. ;)
TS-469 Pro - 3GB RAM (KVR1333D3S8S9/2G) -QTS 4.3.4.1129 Build 20191107 - 4x Hitachi HUA723020ALA640 MK7O - RAID5 - with APC Back-UPS ES 550G

User avatar
Toxic17
Ask me anything
Posts: 5432
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Toxic17 » Fri Nov 04, 2016 10:43 pm

manny2003 wrote:Since release 20161021 hard disks do not spin down anymore. This release does not fix this bug. Reverting back to 20160901 fix the problem.


maybe in your case, however my TS-459 Pro goes into Hibernation running this new Build (1102)
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.2.1354 • TVS-463-16GB 4.4.2.1354 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1161 • APC Back-UPS ES 700G •
QPKG's: Plex 1.19.3 • Apache73 v2443.74070 • QSonarr 3.0.3.809 • QNBZGet 21.0 • phpMyAdmin 5.0.2 • Qmono 6.80.105 • McAfee 3.1.0 -6010 • HBS 3.0.200424 • LEgo v3.6.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+ • UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

manny2003
Getting the hang of things
Posts: 74
Joined: Sun Feb 15, 2015 8:57 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by manny2003 » Fri Nov 04, 2016 11:02 pm

Toxic17 wrote:
manny2003 wrote:Since release 20161021 hard disks do not spin down anymore. This release does not fix this bug. Reverting back to 20160901 fix the problem.


maybe in your case, however my TS-459 Pro goes into Hibernation running this new Build (1102)


Did you experience spin down problem with the previous releases that this new release solved? Or you never experienced it?
I don't know if using the word "hibernation" is quite correct since this could lead to misunderstanding. There is an hibernate function on the NAS, but disks spin down is a different features.
Sorry if I have not understood correctly your report.
Qnap NAS: HS-251 OS Ver. 4.2.2 20160901 | HD: 2x WD40EFRX | RAID: 1 | Used OS: Windows 10 x64
Qnap NAS: TS-251-4GB OS Ver. 4.2.2 20160901 | HD: 1x WD40EFRX | RAID: 0 | Used OS: Windows 10 x64

User avatar
Toxic17
Ask me anything
Posts: 5432
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Toxic17 » Sat Nov 05, 2016 1:24 am

Yes it is misleading. Spin down is set to 30 minutes, and works for me.
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.2.1354 • TVS-463-16GB 4.4.2.1354 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1161 • APC Back-UPS ES 700G •
QPKG's: Plex 1.19.3 • Apache73 v2443.74070 • QSonarr 3.0.3.809 • QNBZGet 21.0 • phpMyAdmin 5.0.2 • Qmono 6.80.105 • McAfee 3.1.0 -6010 • HBS 3.0.200424 • LEgo v3.6.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+ • UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

Undergrid
New here
Posts: 8
Joined: Mon Jul 13, 2015 2:54 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Undergrid » Sat Nov 05, 2016 4:29 am

Same problem here. On my TS-451, every firmware after 4.4.2-20160901 breaks HDD spin-down. In every case setcfg touches uLinux.conf.bak regularly.

Reverting to 20160901 solves the problem.

I haven't tried it on my other NAS's yet.
Last edited by Undergrid on Sat Nov 05, 2016 4:55 am, edited 1 time in total.
Qnap NAS: TS-251+ | OS Ver. 4.3.3.0154 20170413 | 8GB RAM | HD: 2x 4TB (2x WD40EFRX) | JBOD
Qnap NAS: TS-251+ | OS Ver. 4.2.3 20170213 | 8GB RAM | HD: 2x 4TB (1x WD40EFRX, 1x ST4000VN000) | RAID: 0
Qnap NAS: TS-451 | OS Ver. 4.2.2 20160901 | 2GB RAM | HD: 4x 4TB (2x ST4000VN000, 2x HDN724040ALE640) | RAID: 5
Qnap NAS: TS-453A | OS Ver. 4.2.3 20170121 | 16GB RAM | HD: 4x 3TB (4x WD30EFRX) | RAID: 5

manny2003
Getting the hang of things
Posts: 74
Joined: Sun Feb 15, 2015 8:57 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by manny2003 » Sat Nov 05, 2016 4:52 am

Toxic17 wrote:Yes it is misleading. Spin down is set to 30 minutes, and works for me.

Thanks for your clarification. It is interesting that you don't experience the spin down problem. Maybe the TS-459 Pro have something that make the difference... :'

Undergrid wrote:Same problem here. On my TS-451, every firmware after 4.4.2-20160901 breaks HDD spin-down. In every case setcfg touches uLinux.conf.bak regularly.
Reverting to 20160901 solves the problem.

I can observe every aspect you detailed on my side too.
Qnap NAS: HS-251 OS Ver. 4.2.2 20160901 | HD: 2x WD40EFRX | RAID: 1 | Used OS: Windows 10 x64
Qnap NAS: TS-251-4GB OS Ver. 4.2.2 20160901 | HD: 1x WD40EFRX | RAID: 0 | Used OS: Windows 10 x64

User avatar
Toxic17
Ask me anything
Posts: 5432
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Toxic17 » Sat Nov 05, 2016 5:16 am

Might be worth submitting a ticket to QNAP.

Sent from my ONEPLUS A3003 using Tapatalk
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.2.1354 • TVS-463-16GB 4.4.2.1354 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1161 • APC Back-UPS ES 700G •
QPKG's: Plex 1.19.3 • Apache73 v2443.74070 • QSonarr 3.0.3.809 • QNBZGet 21.0 • phpMyAdmin 5.0.2 • Qmono 6.80.105 • McAfee 3.1.0 -6010 • HBS 3.0.200424 • LEgo v3.6.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+ • UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

User avatar
skypx
Easy as a breeze
Posts: 279
Joined: Sat Aug 15, 2009 4:44 pm

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by skypx » Sat Nov 05, 2016 7:03 am

manny2003 wrote:
Toxic17 wrote:Yes it is misleading. Spin down is set to 30 minutes, and works for me.

Thanks for your clarification. It is interesting that you don't experience the spin down problem. Maybe the TS-459 Pro have something that make the difference... :'

Undergrid wrote:Same problem here. On my TS-451, every firmware after 4.4.2-20160901 breaks HDD spin-down. In every case setcfg touches uLinux.conf.bak regularly.
Reverting to 20160901 solves the problem.

I can observe every aspect you detailed on my side too.


I have experienced the same issue with a TVS-871. I have not submitted a ticket to QNAP since it has always been more effort than it worth trying to convince them a specific issue exists.
TVS-871 i7 16GB Ram
Firmware 4.4.2.1270 build 20200410
8x HGST HUH721212ALN600 LEGNT3D0 RAID 5
QNAP Network LAN-10G2T-X550T2
Cisco SG350XG-2F10

manny2003
Getting the hang of things
Posts: 74
Joined: Sun Feb 15, 2015 8:57 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by manny2003 » Sat Nov 05, 2016 8:04 am

skypx wrote:I have experienced the same issue with a TVS-871. I have not submitted a ticket to QNAP since it has always been more effort than it worth trying to convince them a specific issue exists.


I can understand. In any case I found that a good way to point their attention to a problem is to open the ticket linking the discussion here on the forum where many users testify that they face the same exact problem. For this reason it is important, from my point of view, to exchange on a thread as many information as possible and to always leave a post if someone is touched by the same problem.
Qnap NAS: HS-251 OS Ver. 4.2.2 20160901 | HD: 2x WD40EFRX | RAID: 1 | Used OS: Windows 10 x64
Qnap NAS: TS-251-4GB OS Ver. 4.2.2 20160901 | HD: 1x WD40EFRX | RAID: 0 | Used OS: Windows 10 x64

User avatar
Toxic17
Ask me anything
Posts: 5432
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Toxic17 » Sun Nov 06, 2016 1:02 am

skypx wrote:I have experienced the same issue with a TVS-871. I have not submitted a ticket to QNAP since it has always been more effort than it worth trying to convince them a specific issue exists.

So how do you expect this issue to get fixed? I don't think QNAP have a crystal ball.

The more people report this issue especially with different models of NAS the better.

QNAP do not actively monitor these forums. The only way is to raise the issue with them via the online submission form or the "helpdesk" app on your NAS.

Sent from my ONEPLUS A3003 using Tapatalk
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.2.1354 • TVS-463-16GB 4.4.2.1354 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1161 • APC Back-UPS ES 700G •
QPKG's: Plex 1.19.3 • Apache73 v2443.74070 • QSonarr 3.0.3.809 • QNBZGet 21.0 • phpMyAdmin 5.0.2 • Qmono 6.80.105 • McAfee 3.1.0 -6010 • HBS 3.0.200424 • LEgo v3.6.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+ • UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

Undergrid
New here
Posts: 8
Joined: Mon Jul 13, 2015 2:54 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Undergrid » Mon Nov 07, 2016 5:52 am

I've raised a ticket about the issue. If it goes the same as the last time, they'll keep telling me to turn off things that are already off and sending them diagnostic dumps then not get back to me for ages then asking me to do the same thing until I give up.

I'll let you know what happens.
Qnap NAS: TS-251+ | OS Ver. 4.3.3.0154 20170413 | 8GB RAM | HD: 2x 4TB (2x WD40EFRX) | JBOD
Qnap NAS: TS-251+ | OS Ver. 4.2.3 20170213 | 8GB RAM | HD: 2x 4TB (1x WD40EFRX, 1x ST4000VN000) | RAID: 0
Qnap NAS: TS-451 | OS Ver. 4.2.2 20160901 | 2GB RAM | HD: 4x 4TB (2x ST4000VN000, 2x HDN724040ALE640) | RAID: 5
Qnap NAS: TS-453A | OS Ver. 4.2.3 20170121 | 16GB RAM | HD: 4x 3TB (4x WD30EFRX) | RAID: 5

Jacobi
New here
Posts: 6
Joined: Fri Sep 30, 2016 2:42 am

Re: Hard Disks do not spin down - QTS 4.2.2 Build 20161102

Post by Jacobi » Tue Nov 08, 2016 6:09 pm

I have the same problem with my 453A (SSD + 2*8TB). I already have deinstalled each app/service but my two (non raid) hard disks are always making "clickady clack click clack click clack".. and this 24/7. I am about to turn off the qnap and to use something else where the spindown is working..

Post Reply

Return to “HDD Spin Down (HDD Standby)”