QTS 4.3.3 no HDD spindown on fresh install

Discussion about hard drive spin down (standby) feature of NAS.
kliffjack
First post
Posts: 1
Joined: Sat Aug 19, 2017 5:59 am

QTS 4.3.3 no HDD spindown on fresh install

Post by kliffjack » Sat Aug 19, 2017 6:12 am

Hello everybody , just got my new 231P so far so good but no spindown is killing me. :cry:

Run the script and got this :

============= 59/100 test, Fri Aug 18 22:59:21 BST 2017 ===============
<7>[ 5184.370822] setcfg(22791): dirtied inode 2048 (CACHEDEV1_DATA.log) on md9
<7>[ 5184.370891] setcfg(22791): dirtied inode 2048 (CACHEDEV1_DATA.log) on md9
<7>[ 5184.387680] setcfg(22793): dirtied inode 1977 (CACHEDEV1_DATA.lo~) on md9
<7>[ 5184.411832] setcfg(22799): dirtied inode 2048 (CACHEDEV1_DATA.lo~) on md9
<7>[ 5185.878472] setcfg(23290): dirtied inode 1977 (CACHEDEV1_DATA.lo~) on md9
<7>[ 5185.974125] setcfg(23312): dirtied inode 2048 (CACHEDEV1_DATA.lo~) on md9
<7>[ 5186.193587] setcfg(23359): dirtied inode 1977 (CACHEDEV1_DATA.lo~) on md9
<7>[ 5190.062050] kjournald(321): WRITE block 508168 on md9 (8 sectors)
<7>[ 5190.062076] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5190.095247] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5190.097469] kjournald(321): WRITE block 537904 on md9 (8 sectors)
<7>[ 5190.097484] kjournald(321): WRITE block 537912 on md9 (8 sectors)
<7>[ 5190.097496] kjournald(321): WRITE block 537920 on md9 (8 sectors)
<7>[ 5190.097507] kjournald(321): WRITE block 537928 on md9 (8 sectors)
<7>[ 5190.097518] kjournald(321): WRITE block 537936 on md9 (8 sectors)
<7>[ 5190.097529] kjournald(321): WRITE block 537944 on md9 (8 sectors)
<7>[ 5190.097540] kjournald(321): WRITE block 537952 on md9 (8 sectors)
<7>[ 5190.097551] kjournald(321): WRITE block 537960 on md9 (8 sectors)
<7>[ 5190.097563] kjournald(321): WRITE block 537968 on md9 (8 sectors)
<7>[ 5190.097883] kjournald(321): WRITE block 537976 on md9 (8 sectors)
<7>[ 5190.302004] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5190.306579] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5204.402079] kworker/u8:1(8266): WRITE block 262584 on md9 (8 sectors)
<7>[ 5204.402141] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5204.421418] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5204.423098] kworker/u8:1(8266): WRITE block 262616 on md9 (8 sectors)
<7>[ 5204.423114] kworker/u8:1(8266): WRITE block 360456 on md9 (8 sectors)
<7>[ 5204.423134] kworker/u8:1(8266): WRITE block 0 on md9 (8 sectors)
<7>[ 5204.423149] kworker/u8:1(8266): WRITE block 8 on md9 (8 sectors)
<7>[ 5204.423163] kworker/u8:1(8266): WRITE block 262416 on md9 (8 sectors)
<7>[ 5204.423176] kworker/u8:1(8266): WRITE block 262424 on md9 (8 sectors)
<7>[ 5204.423189] kworker/u8:1(8266): WRITE block 262544 on md9 (8 sectors)
<7>[ 5204.632003] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5204.642943] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5190.062076] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5190.095247] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5190.302004] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5190.306579] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5204.402141] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5204.421418] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)
<7>[ 5204.632003] md9_raid1(311): WRITE block 1060216 on sda1 (1 sectors)
<7>[ 5204.642943] md9_raid1(311): WRITE block 1060232 on sda1 (1 sectors)


All Apps are disabled , fresh install , tried unplugging from network still activity on disk. Maybe someone has an idea?

DerKeyser
New here
Posts: 6
Joined: Thu Aug 31, 2017 2:54 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by DerKeyser » Sun Sep 10, 2017 5:32 am

Did you find anything? I have the exact same problem

User avatar
pandatuga
New here
Posts: 4
Joined: Wed Apr 05, 2017 12:40 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by pandatuga » Sun Sep 10, 2017 10:07 pm

Same issue with me after an upgrade a few month ago on my TS-453A
- I have the most current (even beta) firmware
- I stop most of the applications
- there is still no HDD spindown
- After running the diagnostics tools there is still one suspect setcfg(14257): dirtied inode 7011 (uLinux.conf) on md9

I can see a lot of people reporting similar issue on this and other forums

I decided to open support ticket on QNAP

starnap
New here
Posts: 3
Joined: Sat Sep 16, 2017 5:07 pm

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by starnap » Sat Sep 16, 2017 5:21 pm

Hi pandatuga

Have you had any joy when raising a ticket finding out what this was? Also seeing the same thing on TS-453A here.

Cheers

jacobite1
Easy as a breeze
Posts: 342
Joined: Fri Aug 07, 2015 7:02 pm
Location: London, England

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by jacobite1 » Sat Sep 16, 2017 11:37 pm

As a general note, if installed, Plex will prevent HDD spindown even if your QNAP is configured to do so. That's a common issue people have.
TVS-872XT-i5-16GB with 2*WD60EFRX and 4*ST12000VNZ008 in RAID 6.
Backed up to a stack of a half dozen 'cold' external 12TB and 8TB HDDs - please back up your data, RAID is not the same as a backup!

Formerly TVS-463 with 4*WD60EFRX in RAID5, planning to reuse as a backup destination once the EFRXs are freed up.

Protected by an APC SMT750VA UPS - protect your NASes folks!

Philip_with1l
Starting out
Posts: 11
Joined: Wed Dec 21, 2016 7:45 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by Philip_with1l » Sun Nov 05, 2017 8:16 pm

Hey everyone-
I had reported this issue on my TS-451A running 4.2.2 last year. I was advised to upgrade the firmware, which I have, but the issue persists. There are constant Read/Write or drive head action/park activity every 8 seconds, 24 hours a day with nothing running. No thumbnail generation, no streaming, absolutely nothing. I've checked for malware (I think I did that right?) and just opened another ticket because it's driving me nuts.

I want to point out that some expert users in the past have noted that drives spinning down or going to sleep is not entirely important. I am not saying this is correct, just that others have looked into the wear and tear that can happen if a drive has to spin up from sleep over and over. This is a fine option and can help save electricity. Whether it is actually detrimental for a drive to sleep and wake, I'm not sure but I understand the argument.

A more important concern is that the drives are constantly unparking and parking its heads all day long. It would be OK if the drives were just spinning all day with no read/write. That would not be a long-term performance problem at all because that is what NAS drives were made to do..spin all day.
If you want your drives to go to sleep, that's fine and it probably won't hurt. Really we should be concerned about the constant seemingly pointless activity. Yes, NAS drives are meant to read and write information repeatedly. But what we are experiencing is empty pointless writes to the same sector over and over without an associated service or application running. It's as if it's a 10 second loop all day long.

I have tried various combinations of disabling all apps and running services. I have deleted VM's and disconnected the ethernet cables. I have no scrubbing or mirroring going on. No ssh sessions logged in, no Plex encoding. I hope our recent tickets help find resolution. I'm concerned about my drives wear and tear and the noise gets to me after a short time.

User avatar
dolbyman
Guru
Posts: 20041
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by dolbyman » Sun Nov 05, 2017 10:10 pm

so did you run the script to id the writing process ?

Philip_with1l
Starting out
Posts: 11
Joined: Wed Dec 21, 2016 7:45 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by Philip_with1l » Mon Nov 06, 2017 2:22 am

Hi, dolbyman-
Can you clarify which script you're referring to?
I've run the diagnostic tool which analyzes that hard drive activity. At some point, a support rep from QNAP retrieved other data but I forget which method was used.

User avatar
dolbyman
Guru
Posts: 20041
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by dolbyman » Mon Nov 06, 2017 5:14 am


Philip_with1l
Starting out
Posts: 11
Joined: Wed Dec 21, 2016 7:45 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by Philip_with1l » Fri Nov 10, 2017 5:41 am

Hi again-
Yes I just ran the script again and found similar results. However, I am unfamiliar with the process names and cannot interpret which is running or causing a read/write every 8 seconds. Also, which unit in the time stamp indicates seconds?

<7>[21092.133192] nmbd(14207): dirtied inode 105119767 (wins.dat.14207) on dm-2
<7>[21092.133232] nmbd(14207): dirtied inode 105119767 (wins.dat.14207) on dm-2
<7>[21092.133242] nmbd(14207): dirtied inode 105119767 (wins.dat.14207) on dm-2
<7>[21092.133380] nmbd(14207): dirtied inode 105119771 (?) on dm-2
<7>[21112.146217] nmbd(14334): dirtied inode 105119771 (wins.dat.14334) on dm-2
<7>[21112.146235] nmbd(14334): dirtied inode 105119771 (wins.dat.14334) on dm-2
<7>[21112.146375] nmbd(14334): dirtied inode 105119767 (?) on dm-2
<7>[21082.117619] kworker/u4:72(7291): WRITE block 3364093960 on dm-2 (8 sectors)
<7>[21082.117674] kworker/u4:72(7291): WRITE block 0 on dm-2 (8 sectors)
<7>[21082.117699] kworker/u4:72(7291): WRITE block 3363831936 on dm-2 (8 sectors)
<7>[21082.117710] kworker/u4:72(7291): WRITE block 3363832064 on dm-2 (8 sectors)
<7>[21082.117724] kworker/u4:72(7291): WRITE block 3363897616 on dm-2 (8 sectors)
<7>[21087.336398] jbd2/dm-2-8(7866): WRITE block 1921407792 on dm-2 (8 sectors)
<7>[21087.336425] jbd2/dm-2-8(7866): WRITE block 1921407800 on dm-2 (8 sectors)
<7>[21087.336433] jbd2/dm-2-8(7866): WRITE block 1921407808 on dm-2 (8 sectors)
<7>[21087.336440] jbd2/dm-2-8(7866): WRITE block 1921407816 on dm-2 (8 sectors)
<7>[21087.373799] jbd2/dm-2-8(7866): WRITE block 1921407824 on dm-2 (8 sectors)
<7>[21092.545273] kworker/u4:72(7291): WRITE block 3364094616 on dm-2 (8 sectors)
<7>[21097.336054] jbd2/dm-2-8(7866): WRITE block 1921407832 on dm-2 (8 sectors)
<7>[21097.336081] jbd2/dm-2-8(7866): WRITE block 1921407840 on dm-2 (8 sectors)
<7>[21097.336092] jbd2/dm-2-8(7866): WRITE block 1921407848 on dm-2 (8 sectors)
<7>[21097.336102] jbd2/dm-2-8(7866): WRITE block 1921407856 on dm-2 (8 sectors)
<7>[21097.336112] jbd2/dm-2-8(7866): WRITE block 1921407864 on dm-2 (8 sectors)
<7>[21097.336124] jbd2/dm-2-8(7866): WRITE block 1921407872 on dm-2 (8 sectors)
<7>[21097.336132] jbd2/dm-2-8(7866): WRITE block 1921407880 on dm-2 (8 sectors)
<7>[21097.336143] jbd2/dm-2-8(7866): WRITE block 1921407888 on dm-2 (8 sectors)
<7>[21097.379207] jbd2/dm-2-8(7866): WRITE block 1921407896 on dm-2 (8 sectors)
<7>[21102.410840] kworker/u4:72(7291): WRITE block 3363832072 on dm-2 (8 sectors)
<7>[21102.410872] kworker/u4:72(7291): WRITE block 3363897616 on dm-2 (8 sectors)
<7>[21102.410889] kworker/u4:72(7291): WRITE block 0 on dm-2 (8 sectors)
<7>[21102.410900] kworker/u4:72(7291): WRITE block 1608 on dm-2 (8 sectors)
<7>[21102.410915] kworker/u4:72(7291): WRITE block 3363831816 on dm-2 (8 sectors)
<7>[21102.410926] kworker/u4:72(7291): WRITE block 3363831936 on dm-2 (8 sectors)
<7>[21102.410938] kworker/u4:72(7291): WRITE block 3363832064 on dm-2 (8 sectors)
<7>[21117.145455] kworker/u4:0(12224): WRITE block 3364093960 on dm-2 (8 sectors)

User avatar
dolbyman
Guru
Posts: 20041
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by dolbyman » Fri Nov 10, 2017 6:06 am

an older thread .. but check here

viewtopic.php?t=7393

storageneeded
Starting out
Posts: 32
Joined: Sun Jan 01, 2012 2:40 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by storageneeded » Wed Dec 06, 2017 1:58 am

Same issue here with both the version of 4.3.3 my NAS came with (299) and after upgrading. This is right out of the box with even the LAN disconnected from the NAS it still won't spin down or, when it does, the drives spin right back up in a few minutes or less. This is with no added apps or anything enabled beyond the default settings. Clearly the spin down functionality is broken. One or more of Qnap's additions seems to be preventing proper and sustained spin down even on a brand new NAS with nothing installed or connected. It's pretty clear this is a Qnap problem but will they do anything about it? We shouldn't have to be trouble-shooting a problem this obvious and easy to recreate when it's a Qnap issue. It's basic NAS functionality that worked fine back in the QTS 3.x days.

Philip_with1l
Starting out
Posts: 11
Joined: Wed Dec 21, 2016 7:45 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by Philip_with1l » Sun Dec 10, 2017 6:22 pm

Interesting. I agree with you, that it is very trying to keep having to submit logs, disabling every possible app and then submitting more logs but not getting a clear answer.
I see no reason why we should have to disable all of the features on the NAS just to prevent a rogue process from performing read/writes over and over. Something is preventing the drives from resting, and if you have your NAS near your work area then it is really frustrating to hear it do so over and over all day long when there is nothing going on with it.

I have found some leads in disabling the WINS server. Check out the link that dolbyman posted above to see what I mean. I am still engaged with QNAP support to understand what is going on and how to actually use the features of my NAS instead of having to "cripple" it and turn all the cool useful features off just to stop it from damaging the hard drives.

User avatar
dolbyman
Guru
Posts: 20041
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by dolbyman » Mon Dec 11, 2017 12:01 am

how is the NAS damaging the drives?

nas drives are made for 24/7 access

Philip_with1l
Starting out
Posts: 11
Joined: Wed Dec 21, 2016 7:45 am

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by Philip_with1l » Mon Dec 11, 2017 3:37 am

A rogue process is calling for the drive heads on both drives to un-park and re-park for no reason. No data is being called for or written. It happens every 8 seconds or more frequently. So, 7 times a minute, 450 times an hour.
Every day, it is un-parking and re-parking the drive heads 10,800 times for no reason. I'm not concerned about spin-down, as I indicated in a previous reply. I'm concerned that 75,600 times/week the heads on my drives are being called to action and put away for no reason. I could literally do nothing with my NAS (all services disabled and no network connections) and the heads will have been activated over seventy thousand times for no reason. I'd have a week of not using my NAS and all that wear and tear on the components for 0 data purposes.

NAS drives are made to spin and read/write data 24/7, but I've read that it can be detrimental for the arms and heads to go in and out of park so frequently. I'd rather their use be reserved for when I migrate files, sync backups and actually use the drives.
If you have read articles that indicate otherwise, please share them! It is hard to find information on these kind of things.
Thanks for your time!

Post Reply

Return to “HDD Spin Down (HDD Standby)”