QTS 4.3.3 no HDD spindown on fresh install

Discussion about hard drive spin down (standby) feature of NAS.
User avatar
dolbyman
Guru
Posts: 20100
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by dolbyman » Mon Dec 11, 2017 5:08 am

no the arms would only park on powersave/spindown ..not during regular operation.. nas drives also have a (up to) 5 year warranty ..for a reason

User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: QTS 4.3.3 no HDD spindown on fresh install

Post by schumaku » Wed Dec 13, 2017 9:52 pm

Philip_with1l wrote:A rogue process is calling for the drive heads on both drives to un-park and re-park for no reason. No data is being called for or written. It happens every 8 seconds or more frequently. So, 7 times a minute, 450 times an hour.
Every day, it is un-parking and re-parking the drive heads 10,800 times for no reason.
The shortest time QTS does wait on no-activity in the disk cache is five minutes before a spin-down command is sent to the HDD.

The NAS does not force a HDD to park the disks in any way - if it does it's a bug or over-aggressive power saving on your HDD on-board controller, controlled by the HDD firmware, ...

Philip_with1l wrote:Yes I just ran the script again and found similar results. However, I am unfamiliar with the process names and cannot interpret which is running or causing a read/write every 8 seconds. Also, which unit in the time stamp indicates seconds?

<7>[21092.133192] nmbd(14207): dirtied inode 105119767 (wins.dat.14207) on dm-2
<7>[21092.133232] nmbd(14207): dirtied inode 105119767 (wins.dat.14207) on dm-2
<7>[21092.133242] nmbd(14207): dirtied inode 105119767 (wins.dat.14207) on dm-2
What you see here is not parking - it's just causing disk activity most likely. If the arms really go to park position it's off the NAS control. But then - why on earth do you have the WINS service active on your small home NAS? It's known that enabling WINS does cause disk activity. Do you operate multiple IP sub-networks where the legacy WINS is used by old Windows Servers and old Windows clients? Go to the Control Panel -> Network & File Services -> Win/Mac/NFS -> Microsoft Networking -> Advanced Options ... untick the "Enable WINS server" and [Apply].

Further on, I can't find any information on the HDD make, model, and firmware in question. Some HDD vendors have a very flat learning curve, and re-invented wrong defaults on new HDD series repeatedly - ie. WDC copied the s**d WD Green brute force power saving config to almost every coming-up WD Red model series again. Same for almost any other brand, few exceptions only. Check with your HDD maker for the current firmware - if disabling WINS does not cure.

Search the Internet for high load counters - this is not a NAS issue.

Regards,
-Kurt

Post Reply

Return to “HDD Spin Down (HDD Standby)”