Syslog still active even if deactivated in QTS

Discussion about hard drive spin down (standby) feature of NAS.
Post Reply
manto235
New here
Posts: 5
Joined: Sat Aug 08, 2020 3:15 pm

Syslog still active even if deactivated in QTS

Post by manto235 » Tue Aug 11, 2020 2:12 pm

Hi,

I was trying to find the cause of the spin-up of my disks by using the blkdev monitor script and I saw that I have entries related to rsyslogd even though I deactivated Syslog in Control Panel > Applications > Syslog Server.

Code: Select all

"rsyslogd(9756): dirtied inode 13427 (kmsg) on md9"
If I do "ps | grep syslog" and kill the running process, my NAS stays in a standby state.

I have a TS-230 running version 4.4.3.1381.

Did any of you encounter the same issue?
Is there another menu to deactive Syslog?

Thank you
TS-230 | FW 4.4.3.1400 | 2 x 4 TB Seagate IronWolf (ST4000VN008) - RAID 1

dolbyman
Guru
Posts: 19957
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Syslog still active even if deactivated in QTS

Post by dolbyman » Tue Aug 11, 2020 8:59 pm

could be a bug
report it to qnap via ticket

manto235
New here
Posts: 5
Joined: Sat Aug 08, 2020 3:15 pm

Re: Syslog still active even if deactivated in QTS

Post by manto235 » Tue Aug 11, 2020 10:56 pm

Hi dolbyman,

I opened a ticket and someone from the support connected remotely to the NAS.
He hasn't seen any new entries in the standby test he ran while enabling/disabling Syslog.

I saw there are 2 places where Syslog is mentioned in the QTS options:
- Control Panel > Applications > Syslog Server
- Control Panel > System > System logs > Syslog Client Management

Both are deactivated.

However, there is always this process running:
27391 admin 1944 S /usr/sbin/rsyslogd -f /etc/rsyslog_only_klog.conf -c4 -M /usr/local/lib/rsyslog/
TS-230 | FW 4.4.3.1400 | 2 x 4 TB Seagate IronWolf (ST4000VN008) - RAID 1

manto235
New here
Posts: 5
Joined: Sat Aug 08, 2020 3:15 pm

Re: Syslog still active even if deactivated in QTS

Post by manto235 » Sun Aug 23, 2020 3:33 pm

Hi,

A small update:
We performed some checks with QNAP support and even if the rsyslogd process is always running, it does not seem to forbid the system to enter standby mode.
I was running the blkdev script which made me see the rsyslogd entries but the script also forbids the NAS to enter in standby mode.
TS-230 | FW 4.4.3.1400 | 2 x 4 TB Seagate IronWolf (ST4000VN008) - RAID 1

Post Reply

Return to “HDD Spin Down (HDD Standby)”